커뮤니티토픽게시판

https://secure.php.net/supported-versions.php

 

PHP 5.6 보안패치 지원이 2018년 12월 31일부로 종료됩니다.

이것으로 PHP 5.x 버전대는 모두 지원이 종료되는 셈입니다.

 

PHP 7.0은 그것보다 며칠 빠른 12월 3일에 공식적으로 지원이 종료됩니다.

PHP 7.0 지원이 조기 종료되는 게 아니라, PHP 7.0으로 쉽게 업그레이드하지 못하는 사람들을 위해

PHP 5.6을 꽤 오랫동안 지원해 준 것이지요.

 

PHP 7.1은 2019년 말까지, 7.2는 2020년 말까지 지원됩니다.

이후에도 매년 새 버전이 나오고 이전 버전은 지원을 종료하는 숨가쁜 스케줄이 계속 이어질 것으로 보입니다.

 

물론 우분투 16.04 버전에서 기본 제공하는 PHP 7.0은 2021년 4월까지 계속 지원됩니다.

이것도 그다지 긴 시간은 아니라는 것이 함정이지만...

 

센토스 7에서 기본 제공하는 PHP 5.4도 2024년까지 계속 지원됩니다.

이건 워낙 오래된 버전이라 그냥 아웃오브안중 ㅋㅋㅋ

 

글쓴이 기진곰

profile
GitHub 아이디는 @kijin입니다. 사람을 위한 인터넷 생태계의 발전과 웹 보안에 많은 관심을 가지고 있습니다.
오픈소스 도로명주소 검색서버 및 API Postcodify를 개발, 운영하고 있습니다.
우리가 만들어 가는 XE의 새 이름, 라이믹스(Rhymix) 프로젝트에 참여하고 있습니다.
국내외 서버 및 클라우드서버 세팅, 이전, 튜닝해 드립니다.

서버에 요청 중입니다. 잠시만 기다려 주십시오...