푸념에 가까운 글이므로 토픽게시판에 작성합니다

---

 

 

개인적으로(?) 사용할 PHP 프레임워크를 제작하고 있습니다.

 

모 기능과 관련된 라이브러리를 물색하고 있었는데,

7.1 이상의 환경에서만 사용할 수 있는 라이브러리가 마음에 들어서 고민입니다.

 

해당 라이브러리를 사용하게 되면, 7.1보다 낮은 환경에서는 활용을 하지 못하게 되는데.

아직 7.0 환경의 호스팅 서비스가 많다는게 마음에 걸리네요.

 

고객분들께 '적어도 VPS는 들고오시라고요' 라고 말할 베짱(?)이 있다면 딱히 문제될 게 없는데.

그게 아니다보니 7.0 환경을 완전히 포기할 수는 없을것 같고...

 

사실 7.0 환경까지 고려된 라이브러리를 찾거나, 직접 작성하는게 올바른 선택인 듯 한데요.

아직 사람이 덜 됐는지, 검색하기도 귀찮고, 작성하기는 더 귀찮고, 7.0 따위 포기해버리면 간단할 것 같고... 큼...

 

역시 더 노력해야겠습니다.

  • profile
    "7.0 환경까지 고려된 라이브러리를 찾거나, 직접 작성하는게 올바른 선택"
    답을 본인이 아시는것 같네요 ㅎ
  • profile ?
    네, 맞죠...
    답을 아는데도 뭔가 다른 대안이 있을까... 하고 멍청하게도 기대해봤습니다ㅠㅠㅠ
  • profile

    만약 7.1과 7.0 중에서 선택해야 한다면, 저라면 7.0을 배려하는 쪽으로 하겠습니다.

    만약 5.x와 7.x 중에서 선택해야 한다면, 고민하지 않고 5.x는 버리겠습니다.

     

    그런데 XE 모듈이나 애드온이 아니라 개인적으로 사용하실 프로그램이라면 상관없을 것 같기도 합니다.

    국내 최대규모의 모 업체를 포함해서, 7.2~7.3을 지원하는 웹호스팅도 여러 군데 있으니까요.

    VPS를 쓰라고는 못해도 ○○호스팅 ××상품이 필요하다 정도는 말할 수 있지요.

  • profile ?
    좋은 답변 감사합니다ㅠ
    애초에 5.x는 고려 대상이 아니었고, 7.0 을 배려하는 방향으로 잡아보겠습니다ㅠ

    'VPS를 쓰라고는 못해도 ○○호스팅 ××상품이 필요하다 정도는 말할 수 있지요.'
    좋은 팁(?) 감사합니다 (_0_)