질문글이라 질문게에 올립니다. wappalyzer로 웹 사이트 라이브러리 같은거 보는게 은근 재미있는데 한가지 눈에 띄는 건 우리나라 사이트가 유독 제이쿼리 1.x 기반이 많았다는 점입니다. 심지어 최신사이트인 라프텔도 보면 제이쿼리 1.x라더라고요.

 

왜 제이쿼리 1.x에 머무는 사이트가 많은지 궁금합니다.

  • profile

    인터넷 익스플로러 정식 지원종료된 지 이제 겨우 한 달 지났습니다.

    1.x와 2.x는 기능 차이도 없고, 성능 차이가 있다고 해도 눈에 띌 정도는 아니니

    그냥 안전빵으로 1.x 쓰는 거죠. ㅎㅎ

  • profile
    반대로 왜 2.x 를 써야하는지 생각해보시면 됩니다.
  • profile profile
    저는 3.x를 써야한다고 생각하는 쪽입니다. 솔직히 2018-2019는 IE가 거의 11로 되서 3.x를 써도 무방하다고 생각합니다.
  • profile profile

    딱 IE 지원만 뺐다면 환영할 텐데, 3.x는 아예 함수를 없애버린 것이 많아서 오래된 코드베이스를 마이그레이션하기 쉽지 않습니다. 심지어 jQuery migrate도 예전 것과는 호환이 안 되더라구요. 라이믹스처럼 서드파티 자료까지 지원해야 하는 형편에서는 영원히 2.x에 머물러야 할지도...

  • profile profile
    워드프레스 같은 해외 CMS는 그냥 과감하게 3.X를 사용하고 있습니다. 근데 라이믹스 같은 경우는 생태계가 많이 부족해서 하위호환에 의존해야 하는 상황이라 흠......