질문/조언질답게시판
Extra Form
PHP PHP 8.0
CMS Rhymix 2.x

 

 

인덱스 화면 무사히 설치 되어서 게시판을 누르는 순간 다른 페이지들이 연결이 안되는 것 같습니다.

 

현재 인덱스화면과 관리자 화면만 연결이 되는데 이유가 무엇일까요?

 

/etc/nginx/sites-enabled/default 파일에 

 

include snippets/rhymix.conf; 인클루드 규칙이 빠져서 그런가 하고 넣어보니 오류가 떠버리네요.

 

라이믹스 업로드도 다시 한번 실행해 봤는데 같은 증상입니다.

 

이런 경우는 어디가 문제가 있는 것일까요? 

 

오류 메세지가 없으니 당황스럽네요. 

 

php 8.0 

LEMP 세팅입니다. 

  • profile

    rhymix.conf를 인클루드하지 않으셨다면 당연히 짧은주소는 모두 오류가 나지요.
    인클루드했을 때 오류가 뜬다면 nginx 에러로그에 관련 내용이 남을 테고요.

     

    /etc/nginx/sites-enabled/default 의 내용을 올려주셨다면 더 도움이 되었겠지만
    https://rhymix.org/manual/introduction/nginx 에서 "주의:"로 시작하는 문단을 읽어보세요.
    인클루드시 오류가 뜨는 것은 이것 때문인 경우가 대부분입니다.

  • profile profile
    파일 설정은 이렇게 했습니다.
    include snippets/rhymix.conf; # 라이믹스 rewrite 규칙 인클루드
    를 넣어서 오류 메세지를 출력하게 해놓았습니다.



    server {
    listen 80 default_server;
    listen [::]:80 default_server;


    root /var/www/html;

    # Add index.php to the list if you are using PHP
    index index.php index.html index.htm index.nginx-debian.html;
    client_max_body_size 32m;
    server_name 193.123.234.176;
    index index.html index.htm index.php; # index.php가 반드시 포함되어 있어야 합니다.

    include snippets/rhymix.conf; # 라이믹스 rewrite 규칙 인클루드



    location / {
    # First attempt to serve request as file, then
    # as directory, then fall back to displaying a 404.
    try_files $uri $uri/ =404;
    }

    # pass PHP scripts to FastCGI server
    #
    location ~ \.php$ {
    include snippets/fastcgi-php.conf;
    fastcgi_pass unix:/run/php/php8.0-fpm.sock;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
    fastcgi_read_timeout 300;
    }

    location ~ /\.ht {
    deny all;
    }
    }


    오류 메세지는 아래와 같습니다.
    nginx: [emerg] open() "/etc/nginx/snippets/rhymix.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/default:15
    nginx: configuration file /etc/nginx/nginx.conf test failed
  • profile profile
    No such file or directory , 파일또는 디렉토리가 존재하지 않는다네요.
  • profile profile
    디렉토리부터 찾아야겠네요. 감사 합니다. 



    :~$ grep -r "listen =" /etc/php/8.0/fpm/pool.d

    /etc/php/8.0/fpm/pool.d/www.conf:listen = /run/php/php8.0-fpm.sock

    /etc/php/8.0/fpm/pool.d/www.conf:;pm.status_listen = 127.0.0.1:9001



    이런 메세지가 떠서 

    fastcgi_pass 127.0.0.1:9001; 이거 한줄은 더 추가 했습니다.
  • profile

    도움 주신 덕분에 잘 해결이 되었습니다. 지난번에도 여기서 막혔던것 같은데 그 새 또 잊었었던것 같습니다.

    짧은 주소 규칙을 별도로 만들어서 넣어주어야 하는 것이였네요. 

    같은 증상이 있는 분들은 아래 내용으로 해결 하시면 될것 같습니다. 

     

    "최근 Ubuntu에서는 nginx와 관련된 잡다한 설정파일들은 /etc/nginx/snippets 폴더에 넣는 것이 관례입니다. 라이믹스에서 제공하는 rewrite 규칙 파일을 다운받아 이 폴더에 rhymix.conf라는 이름으로 넣습니다."