질문/조언질답게시판
Extra Form
PHP PHP 7.0
CMS Rhymix 2.x

제로보드로 만들어서 운영할땐 내가원하는 기능을 장터에서 구매해서 쓰거나 했는데요.

 

라이믹스는

최신 업데이트 XE 모듈, 플러그인, 테마를 사용할 수 있다고 알고 있습니다. 

그러나

구버전이 아닌, 최신버전 XE모듈이라도

라이믹스에서 사용이 불가능한 경우도 있는지 궁금합니다.

 

저는 최신 XE모듈들은 라이믹스에서 사용하는데 대부분 문제가 없다고 알고 있습니다만

 

라이믹스 전용 모듈들은 전부 XE사용불가 모듈들이더군요.

 

시간이 지나면서 점점

최신 XE모듈이라도

라이믹스에는 사용불가 문제가 생기지 않을까 좀 걱정되네요.

 

읽어주셔서 감사합니다.

  • profile

    해당 모듈 제작자분이 대응하기 나름입니다. 특정 모듈에 대해 논의해 볼 수는 있겠으나, 모듈마다 천차만별이기 때문에 그냥 뭉뚱그려서 호환성을 이야기하는 것은 무의미합니다.

     

    최근에 업데이트된 모듈이라도 XE 공홈 쪽에서만 활동하시고 라이믹스에 관심이 없는 제작자분이라면 XE에서만 호환되도록 만들었을 수 있습니다. 반면, 오래된 모듈이라도 처음부터 구조를 원만하게 잘 만들어 놓았다면 XE든 라이믹스든 문제 없이 돌아갈 수도 있습니다. PHP 버전만 맞으면 XE든 라이믹스든 잘 돌아가기도 하고, 아예 안 돌아가기도 합니다.

     

    그래서 모듈의 외관만 보지 말고 제작자분의 평판과 커뮤니티 활동 실적, 업데이트 내역 등을 자세히 보셔야 합니다. 예를 들어 최근 업데이트 내역에서 라이믹스가 종종 언급된다면 라이믹스에 대응을 하고 계실 가능성이 높습니다. 반면, 5년 전부터 잠수함에서 근무하고 계신 분이라면 라이믹스는 고사하고 XE 최신 버전에서도 에러가 날지도...

  • profile profile
    명쾌한 답변 감사드려요. 기진곰님의 설명을 보면, 전문 컨설팅을 하셔도 될 것 같습니다.
    보통 사람들은 개발자분들이 하는 말을 알아듣기가 어렵거든요.
    헌데 기진곰님은 굉장히 쉽고 명확하게 설명해주시니
    단번에 해결되네요.