질문/조언질답게시판
Extra Form
PHP PHP 7.0
CMS XpressEngine

현재 ubuntu16.04 + nginx + php7.0-fpm + mariadb 를 사용 중입니다.

 

라라벨프레임워크를 사용해보려고 ㅠㅠ

php7.4를 사용하고 싶어서 업그레이드를 하려고 하는데요,

 

지금 현재 사용 중인 nginx랑 php7.0-fpm은 중지 후에 php7.4-fpm을 설치 할 수 있나요?

 

> 설치는 중지 없이도 할 수 있군요!;;

 

xetown-20200502.png.jpg

 

현재 sudo apt -y install php7.4 입력하고 이 단계까지 왔는데 그냥 현재 버전 유지로 선택하고 ok 가면 되나요?

  • profile
    https://eond.com/phpinfo.php
  • profile

    댓글의 링크처럼 phpinfo 를 php파일로 만들어서 두는것은 매우 위험하고 보안에 취약한 행동입니다.

    지금은 조금 늦었지만.. 그래도 지금이라도 저 phpinfo.php 파일을 지우시는게 좋으실 겁니다.

    운영체제 정보부터 시스템 정보까지 다 나오네요 ..

  • profile
    그리고 php 업그레이드는 우분투 사용중이시라면 apt update -y; apt upgrade -y 명령어 입력하시거나
    do-release-upgrade -d 하여 우분투를 업그레이드하여 php 같은 패키지들을 업그레이드 하는 방법이 있습니다.