질문/조언질답게시판
Extra Form
PHP PHP 7.2
CMS Rhymix

스크린샷, 2020-02-15 21-12-45.png

위의 사진처럼 스티커 모듈에서 GD_library_is_not_installed 에러가 납니다.

서버 재설치 하고 php7.2, apache2. mysql, apache rewrite_module 등등 다 깔았습니다.

어떻게 해야 좋을까요?

 

조언 좀 구하겠습니다.

 

 

혹시 몰라 서버 환경 남겨드립니다.

 

[Basic Information]
rhymix_version : 1.9.9.2
date : 2020-02-15 21:17:53 +0900
php : 7.2.24-0ubuntu0.18.04.2 (64-bit)
server : Apache/2.4.29 (Ubuntu)
os : Linux 5.3.0-28-generic
sapi : apache2handler
baseurl : https://www.ilbesecond.net/
basedir : /home/jeongyongjin/public_html/
owner : jeongyongjin (1000:1000)
user : www-data (33:33)
ssl : always

[System Settings]
db.type : mysql (innodb, utf8mb4)
db.version : 5.7.29-0ubuntu0.18.04.1
cache.type : redis
locale.default_lang : ko
locale.default_timezone : Asia/Seoul
locale.internal_timezone : 32400
mobile.enabled : true
mobile.tablets : true
session.use_db : true
session.use_keys : false
session.use_ssl : false
session.use_ssl_cookies : false
view.concat_scripts : none
view.minify_scripts : none
use_rewrite : true
use_sso : false

[PHP Settings]
session.auto_start : 0
max_file_uploads : 20
memory_limit : 1024M
post_max_size : 256M
upload_max_filesize : 256M
extensions : calendar, curl, dom, exif, fileinfo, ftp, gettext, hash, iconv, igbinary, json, libxml, mbstring, memcached, msgpack, mysqli, mysqlnd, openssl, pcre, pdo, pdo_mysql, phar, posix, readline, redis, shmop, simplexml, sockets, sodium, sysvmsg, sysvsem, sysvshm, wddx, xml, xmlreader, xmlwriter, xsl, zend opcache, zlib

[Modules]
module : accessuser (1.0.2), ad (0.6.4), adminex (0.15), adminlogging (1.7), admin_menu (1.0), advanced_mailer (2.1.0), attendance (7.2.5), blind (0.3), board (1.7.2), bookmark (0.1), detail_search (0.1), directmessage (0.1), gradeup (1.0.0), imageprocess (2.6.6), kin (1.7.0), krzip (1.8.0), loginlog (1.5.0), ncenterlite (3.1), pointhistory (0.2.1), pointsend (1.3.0beta), randocument (1.0), resource (1.7.0), rockgame (0.4), sejin7940_nick (1.2), seo (1.9.0), sitemap (1.3), sitemaplite (1.1.2), sticker (0.0.0), supercache (1.3.7), vote (1.1.4)

[Addons]
addon : addvote (1.0), adminlogging (1.7), captcha_member (1.7), custom_cookie (0.1), division (1.0), highslide-xe (1.0), member_join_extend (0.1), member_pointsend (0.2.1), notifyjs (0.1), oembed (1.0), photoswipe (1.0.1), recaptcha (1.0.0), sejin7940_addvote (1.3), sejin7940_autotrash (1.1.1), session_shield (2.0.1), soo_parking (0.25), source_marking (0.3), xdt_google_analytics (1.1)

[Layouts]
layout : br_800px (1.0), br_chat (1.0), elkha_graystyle (2.2.1), hestia (2.1.4), simple_world (1.1.0), user_layout (1.7), xedition (1.9)

[Widgets]
widget : bannerWidget (0.6), contentextended (2.45), counter_status (1.7), level_point (1.0), lineadWidget (0.9), moonchat (3.0), pollWidget (2.0), popular (0.1), soo_kma_rss (0.3.1), uchat2 (1.0.8)

[Widgetstyles]
widgetstyle : gray_style (1.2.1), simple (1.7), sweetMobileWidgetStyle (1.7), tirano (0.1)

  • profile
    gd 안보이네요 ;;;
  • profile profile

    GD_library_is_not_installed 입니다.

     

    봐서는 어디가 설치가 안됬다고 하는 것 같은데 이게 무슨 말인지요...

  • profile profile

    제 테섭기준으로 보면
    extensions : calendar, curl, dom, exif, fileinfo, ftp, gd, gettext, hash, iconv, imap, intl, json, ldap, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, pdo, pdo_mysql, phar, posix, pspell, readline, shmop, simplexml, soap, sockets, sodium, sysvmsg, sysvsem, sysvshm, wddx, xml, xmlreader, xmlwriter, xsl, zend opcache, zlib
    이렇게 나옵니다.

    gd 가 있죠

  • profile profile
    sudo apt-get install php-gd 로 해결했네요.

    감사합니다.
  • profile
    일베 세컨드 사이트도 있군요

서버에 요청 중입니다. 잠시만 기다려 주십시오...