질문/조언질답게시판
Extra Form
PHP PHP 7.0
CMS Rhymix 1.x

제가 카페24 쓰거든요

php 7.0

마리아 디비 쓰는데요

10년 정도 있다가 호스팅 회사에서 

서버 환경을 맘대로 바꾸지 않겠죠????????????????

초짜인 저는 서버 버전이나 디비 버전 대해 잘 모르는데....

호스팅 회사가 뭐 뭐 바꾼다고 하면 저는 큰일인데 그렇죠?

갑자기 화장실에서 생각이 나서....

 

  • profile

    보통 그런경우라면 호스팅에서 안내해주고 이전을 도와주는 경우도 있습니다.

    그리고 아직도 php4 버전대의 호스팅의 서비스를 끊지 않은 경우도 많기에 호스팅에서 막 서비스를 중단하고 그러진 않을거예요.

    문제가 잇을때 1~2년 정도의 유예기간을 지원하는 경우도 있습니다. 관련 내용은 대부분 약관으로 확인하시고 약관 변경공지 같은것들도 메일로 오면 바로바로 확인하고 기억해두시는게 좋겠습니다.

    그 동안 부족하시겠지만 공부하고 충분히 이전은 하실거라 생각합니다.

  • profile ?

    아하~ 이전을 도와주시는거군요. 다행 ^^

    그런데 php4는 뭐에요? 혹시 제로보드4??

  • ? profile
    음… 저도 잘 모르지만 PHP7보다 낮은 버전의 PHP 아닐까요…?
  • ? profile
    이전을 모두가 도와주진 않고 보통은 도와주는 경우가 있을 뿐이죠.

    PHP버전이 5 버전 7버전 이렇게 있듯이 PHP4는 10년전 php버전이라고 생각하심 됩니다.

    그만큼 오래된 버전이 아직도 지원하고 있다는 것이고요.. 너무 업데이트에 대해 뭔가 작업하시면서 많이 데이신것 같으신데.. 상황에 따른 문제점 파악능력을 차근차근 길러보시는게 좋을 것 같습니다.
  • profile

    현재 사용하는 php버전을 10년 동안 사용한다는 것은 사용하는 CMS(라이믹스 등) 의 업데이트를 포기한다는 것과 비슷한 이야기 입니다.

     

    라이믹스의 현재시점에서 공지하고 있는 최소,권장 버전

     

    라이믹스를 설치하고 원활하게 사용하려면 아래와 같은 조건이 갖추어져야 합니다.

    PHP 7.0 이상 (PHP 7.2 이상 권장)
    2021년 하반기 이후: PHP 7.2 이상 (PHP 7.4 이상 권장)

     

     

    php 버전이 발표됨에 따라 시간이 지나면 라이믹스도 최소 요구 버전은 올라가게 됩니다. (버전이 낮으면 더이상 최신 버전의 라이믹스를 사용하지 못하게 됩니다.)

     

    라이믹스 구버전을 쓴다는 것은 라이믹스의 최신 기능을 사용하 수도 없고 구버전 보안패치가 종료되는 시점에서는 사이트의 보안에 심각한 문제를 안고 운영하시게 됩니다. 

  • profile

    한 번 만들어 놓으면 10년 동안 그냥 둬도 잘 굴러갈 것이라는 이런 마인드가 문제입니다. 정부부터 민간기관까지 우리나라 대부분의 사이트는 만들어 놓기만 하고 유지보수를 안 해서 허구헌날 해킹당하기나 하지요.

    업데이트는 매달 하셔야 하고, PHP 버전도 2~3년에 한 번쯤은 올려주시는 것이 좋고, 호스팅 업체나 상품도 10년에 2~3번은 옮겨다니실 생각 하고 거기에 맞추어 계획을 세우시기 바랍니다. 대략 휴대폰을 바꿀 때쯤 되면 호스팅도 바꿔주는 것이 좋습니다. 10년이면 강산이 바뀐다는데 인터넷 환경이나 호스팅 업체의 상품 구성은 안 바뀔까요? 그렇게 시대에 뒤떨어진 사이트를 계속 운영한들 누가 찾아올까요?