질문/조언질답게시판
Extra Form
PHP PHP 7.2
CMS Rhymix

안녕하세요.

금일 리눅스 커널을 업데이트 했습니다

 

 

CentOS Linux (3.10.0-957.el7.x86_64) 7 (Core) 에서

CentOS Linux (5.7.6-1.el7.elrepo.x86_64) 7 (Core) 로

업그레이드 했는데

 

기존에는 되던 인터넷이 작동 되지 않습니다.

혹시 새 커널에서는 랜카드를 못잡는 증상 있어본적 있으신가요?

 

다시 과거 커널로 부팅하긴했는데... 뭔가 최신버전 쓰고싶은데 너무 찝찝하네요.

 

혹시 해결방법 아시는분 계신지 아니면 비슷한 증상을 겪어보신분이 있는지 자문을 구하고 싶습니다.

 

 

20200630_181641.jpg

인터넷이 정상작동되는 3.10 버전 네트워크 랜 그림이 상단에 떠있습니다.

20200630_182451.jpg

유선 연결됨 - 1000 Mb/s 라고 적혀 있습니다.

 

 

20200630_181413.jpg

인터넷이 안되는 5.7 버전 네트워크 아이콘이 없습니다.20200630_181429.jpg

인터넷이 안되는 5버전 유선 랜정보가 없습니다.

  • profile
    https://downloadcenter.intel.com/download/14687/Intel-Network-Adapter-Driver-for-PCIe-Intel-10-Gigabit-Ethernet-Network-Connections-Under-Linux-
    이거랑 연관성이 있는지 확인 중 입니다.
  • profile
    최신버전이 무조건 좋은것은 아닙니다. 디바이스 드라이버가 최신 커널을 지원하지 않으면, 로드가 되지 않을수 있습니다.

    특히 위에 댓글로 달아주신 링크 역시 리눅스 커널 5.6 지원을 추가했다고 되어 있습니다. 즉, 5.7 버전은 지원하지 않을 가능성이 높습니다. 리눅스 커널의 경우 반드시 필요한 것이 아니라면 업그레이드하지 않으시는걸 권장드립니다.
  • profile profile
    답변 감사드립니다!
    조금 초보적인 질문인데 커널이 윈도우로 보면 서비스팩과는 다른의미일까요?
    뭔가 최신버전을 하지 않으면 안될 것 같은 느낌이 들어서요
    3버전은 너무 오래된 것같기도하고요
  • profile profile

    아뇨. 다릅니다.
    https://www.kernel.org/

    위 사이트 접속해서 보시면 아시겠지만, longterm 버전이라고 해서 아직도 3.16버전대 커널이 지원되고 있습니다. 이와 별개로 RHEL/CentOS, 우분투 등은 OS 개발사에서 자체적으로 커널에 보안패치 등을 적용하고 있습니다.

    즉, PHP 5.4 버전이 위험해 보이지만, CentOS를 사용중이라면 레드햇에서 패치를 진행해 주므로 상관 없듯이, 리눅스 커널 버전 역시 기본 제공되는 버전은 해당 OS 지원기간중 계속해서 보안패치를 받으므로 신경쓰지 않으셔도 됩니다. 오히려 임의로 최신버전 설치시 지원기간이 더 짧아 수시로 커널 업그레이드를 해야 하는 불편함이 따를수 있습니다.(보통 홀수 버전은 불안정 버전으로 오래 지원하지 않습니다.)

    다만 오래된 버전을 사용하면 최신 커널에 포함된 기능은 사용할수 없긴 합니다. 하지만 실제로 최신 커널의 기능이 필요한 경우는 극히 드물기 때문에 굳이 업그레이드하실 필요는 없습니다.

    만약 굳이 업그레이드를 해보고 싶으시다면, 해당 디바이스에 맞는 드라이버가 지원하는 최신 커널 버전 확인하시고 설치하시면 됩니다.(만약 위에 다신 링크의 드라이버가 지원하는 제품이라면 5.6 버전이 됩니다.)