물어보기Rhymix
조회 수 92 추천 수 0 댓글 9
Extra Form

소셜계정 로그인 실패 문의드립니다.

소셜XE 로 로그인 시 "API 통신 오류입니다. 재시도 해주세요." 오류가 발생합니다.

카카오계정의 경우 로그인 알림톡까지 왔는데 오류가 발생하는거라 확인이 쉽지 않네요.

SSL 미적용 상태이며 서버정보는 아래와 같습니다.

아무래도 서버 환경상의 문제인 듯 싶은데

뭘 확인해봐야 할까요?


rhymix_version : master 1.9.3 php : 7.1.12 (64-bit) server : Apache/2.4.29 (CentOS) os : Linux 2.6.32-696.20.1.el6.x86_64



  • profile
    사과맛스타 2018.03.13 01:43:42
    모든 소셜 로그인 방식이 동일한 증상을 보이나요? 아니면 특정 소셜 로그인만 그러나요?
  • 카이로스 질문자 2018.03.13 07:59:59
    모두 그렇습니다
  • 사과맛스타 2018.03.13 08:33:58
    @카이로스
    그럼 뭔가 설정이 잘못된거 아닐까요?

    가령 예를 들면 사이트 등록할 때 https에서 s를 뺐다거나 그런..
  • 카이로스 질문자 2018.03.13 09:17:52
    @사과맛스타
    사이트 등록은 [시스템설정 - 사이트 설정]을 말씀하시는거죠?
    도메은 정상 등록되어 있고 https 는 사용하지 않음으로 설정되어 있습니다.
  • 사과맛스타 2018.03.13 10:41:13
    @카이로스
    소셜 xe설정부분을 말하는거였습니다.
    전체적으로 api통신 오류가 난다면 설정이 잘못되었울 가능성이 높고 두번째로는 도메인 주소가 한글 주소나 그런식으로 조금 독특한 경우에 문제가 발생하더군요.
  • 카이로스 질문자 2018.03.13 14:30:45
    @사과맛스타
    네.. 답변 감사합니다.
    그런데 소셜XE API 설정에 Callback URL은 수동설정이 아닌데
    어떤 걸 말씀하시는건지 잘 모르겠어요.. ^^;;
  • 사과맛스타 2018.03.13 15:46:42
    @카이로스
    저도 이제 그 이상은 모르겠어요~
    죄송합니다. ^^;;
  • 카이로스 질문자 2018.03.13 16:05:57
    @사과맛스타
    죄송하긴요~ 감사합니다.
    더 디버깅 해봐야겠네요~^^
  • profile
    카이로스 질문자 2018.03.13 15:30:28
    디버그 로그를 보니 socialxe.clsss.php 의 아래 라인에서 Warning이 발생하네요.
    require_once('modules/socialxe/socialxe.library.php');

    01. Warning: Declaration of socialxeLibrary::get() should be compatible with BaseObject::get($key)
    - C:\APM\nginx\html\modules\socialxe\socialxe.class.php line 175
    - C:\APM\nginx\html\modules\socialxe\socialxe.class.php line 175

서버에 요청 중입니다. 잠시만 기다려 주십시오...