안녕하세요.

 

앞으로 제 오픈소스 자료는 이제 XE와의 하위호환성을 깹니다.

 

GPL v2 기준으로 배포되는 모든 자료가 주를 이루게 될거고, XE의 하위호환성이 깨지는 순간부터는 보안 패치및 모든 자료패치를 받지 못하게 될겁니다.

 

모든 패치의 방향은 라이믹스에서 사용되는 모든 최신코드 기반을 기준으로 하기 때문에 기존버전의 라이믹스 혹은 XE를 쓰시는 분들이라면 얼른 업데이트 하시길 권장드립니다.

 

모든 자료의 기준은 라이믹스 2.0.20 버전 이상에서만 작동가능하도록 할 가능성이 크니 아직 안하신분들 계신다면 꼬옥 업데이트 하시길 권장드립니다 ㅎㅎ 

 

일부 많이 사용되는 출석부 메달 시스템정도는 라이믹스 1.9까지 호환성은 유지하겠으나 앞으로 패치할 자료들은 라이믹스 2.0.20버전이 기준이 될 가능성이 큽니다.

 

(이렇게라도 강제적으로 라이믹스 업그레이드를 부축여 봅니다 ㅋㅋㅋ)

글쓴이 람보

profile
람보입니다.
  • profile
    언젠가는 해야해야하는 일이었다고 생각합니다 ㅎㅎ
    그동안 지원해주신것도 정말...ㄷㄷ 항상 좋은 자료/정보 감사합니다~
  • profile
    감사합니당,
    하니씩 2.0.20으로 올리고 있습니다. ㅎㅎ
  • profile
    저도 따르겠습니다, 라고 생각했는데 사실 저는 늘 최신판 코어를 기준으로 작업을 해왔었네요.(물론 별 생각도 없이요ㅋㅋ)
    말씀하신 것처럼 주요 서드 파티 자료들에 제한점이 있어야 xe에서 라이믹스로 넘어가고, 업데이트도 따라가고, 또 궁극에는 가급적 코어 수정을 하지 않을 수 있는 것 같아요.
    암튼 적극 지지합니다!
  • profile
    좋은 소식입니다!!! XE유저들을 라이믹스로 강제 이동!!!
  • profile

    많은 분들께 죄송스럽지만.. 위의 글에 작성한바와 같이 라이믹스 1.9를 몇몇 모듈애서 유지를 할 계획이엿지만, https://github.com/rhymix/rhymix/pull/1292 가 2.0이상에서만 지원하기에 1.9이하의 모든 지원버전을 지원한다는건 xe의 호환성을 그대로 유지하는 것과 같아 번복을 하게 될듯 합니다.

    빠른시일내로 2.0이상으로 업데이트 하시는걸 권장하는 마음에서 하위 호환성을 그냥 앞으로는 깨버리고 2.0이상에서만 생각하구 개발하도록 하겠습니다. (_ _ )