질문/조언질답게시판

안녕하세요,

XE 로 만든 홈페이지 운영중인데 현업체 대응이 너무 부실해서 옮기려고 합니다.

서비스 신청 작성 중 계정정보에 서버 타입 설정이 있더라고요...

제가 개발자도 아니고 이런쪽엔 문외한이라...

다음과 같이 선택을 하라고 하면서 세팅 후 변경 불가라고 하니... 뭐로 선택해야 하는지 조언 부탁합니다.

 

1. EUC-KR(Mysql5.0), PHP5.2

2. UTF8(Mysql5.1), PHP5.2

3. EUC-KR(Mysql5.5) PHP5.5

4. UTF8(Mysql5.5), PHP5.5 

5. UTF8(Mysql5.5), PHP7.0

 

※ 서버 타입은 셋팅 후 변경이 불가능 하오니 신중한 선택을 바랍니다.
※ "홈즈" 사용 예정 고객은 'EUC-KR(Mysql5.0) PHP5.2'로 선택하셔야 지원가능합니다.
  • profile

    1~3. EUC-KR과 PHP 5.2는 XE와 호환되지 않습니다.

     

    4. XE 구버전 그대로 쓰신다면 그나마 괜찮은 선택입니다. XE 최신버전은 3월부터 PHP 5.6 이상 버전만 지원하겠다고 예고된 상태이므로, PHP 5.5에서는 업데이트가 곤란할 수 있습니다.

     

    5. XE 최신버전으로 운영하신다면 PHP 7.0이 최선의 선택입니다. 지금도 쓸 수 있고, 3월 이후에도 계속 쓰실 수 있습니다. 단, 기존에 낮은 버전에서 운영하시던 사이트라면 일부 모듈이나 애드온 등이 오류를 일으킬 수 있으니 XE타운에 질문 많이 하셔야 할지도 모릅니다^^

  • profile ?
    상세한 답변 감사합니다.
    제가 2017년 8월에 다운받아 설치했으니 아마 xe 2.0 으로 판단됩니다. 이게 구버전 맞나요?
    5번으로 선택하는게 최선일 거 같은데 구버전 사용으로 모듈이나 애드온 오류 발생 가능성이 있다면 xe 최신 버전 업그레이하면 되는 것이겠지요?
  • ? profile
    Xe는 아직 1.x 버전 대 입니다.

    Xe2를 뛰어 넘고 xe3를 개발하고 있으나 아직 xe1 입니다.
  • ? profile
    XE 2.0이라는 건 없고요... 아마 1.8.xx 버전일 것 같네요. 그 정도만 되어도 XE 자체의 호환성 문제는 없습니다만, 추가로 어떤 모듈이나 애드온을 쓰시는지에 따라 그쪽에서 문제가 발생할 가능성은 있습니다.
  • profile
    5번 하시면 됩니다!

서버에 요청 중입니다. 잠시만 기다려 주십시오...