안녕하세요.

예전에도 한번 질문 드렸었는데 이번에 라이믹스로 버전을 변경한 후에도 같은 증상이 있어 문의 드립니다.

현재 mp3와 mp4 등, 음악과 동영상이 자동으로 본문삽입 및 플레이가 되도록

멀티미디어 링크 컴포넌트 개조

HTML5 AUDIO to FLASH

HTML5 VIDEO to FLASH

자동 embed 삽입 애드온(oEmbed)

이렇게 4가지 사용하고 있습니다.

 

헌데, 예전에 XE 사용할 때도 그랬고, 라이믹스 현재 버전을 사용할 때도 관리자를 제외한 

나머지 회원들은 본문삽입이 안되고 있습니다.

참고로 그림 파일은 잘됩니다. ㅎㅎ

혹시 증상에 대해 아시거나 해결하신 분 계신다면 댓글 부탁 드립니다.

 

혹시, 사이트에 대한 테스트가 필요하시다면 쪽지 주시면 관리자 권한과 일반 회원 권한이 있는

아이디와 주소를 전달 드리겠습니다.

 

많이 바쁘신 가운데 꼭 답변 부탁 드립니다. ㅠㅠ

 

 

 

  • profile
    참고로 일반 회원이 올리면
    <img rx_encoded_properties="" src="/common/img/blank.gif" editor_component="multimedia_link" width="400" height="320" style="display:block;width:400px;height:320px;border:2px dotted #4371B9;background:url(&quot;./modules/editor/components/multimedia_link/tpl/multimedia_link_component.gif&quot;) no-repeat center;" alt="" />
    이런 코드가 되구요

    관리자로 올리면
    <img src="/common/img/blank.gif" editor_component="multimedia_link" multimedia_src="/RX_2017/files/attach/images/187/787/0ecd5eec46b968a693648bd9b1da42ec.mp3" width="400" height="320" style="display:block;width:400px;height:320px;border:2px dotted #4371B9;background:url(./modules/editor/components/multimedia_link/tpl/multimedia_link_component.gif) no-repeat center;" auto_start="false" alt="" />

    이러한 코드가 됩니다.ㅠㅠ
  • ?
    멀티미디어 컴포넌트를 어떻게 개조하셨나요?
  • ? profile
    기존 컴포넌트의 이름 "멀티미디어 링크 컴포넌트 개조"
    개조라는 단어가 들어있습니다.
    XE 공식 자료실에 있는 참빛바다님의 컴포넌트를 말하는것 같네요.
  • profile
    예전에 XE 사용할 때도 안되고, 라이믹스에도 되지 않는다면
    만성소년님의 컴포넌트가 잘못되어 있을 수 있습니다.
    멀티미디어 링크 컴포넌트 개조 컴포넌트에 문제가 있을 수 있으므로
    기존것을 삭제하시고 다시 받아 업로드하여 실행해 보시길 바랍니다.
    혹시나 싶어 XE,라이믹스 테스트하여 보니 정상적으로 작동이 됩니다.
    혹시나 저만 잘 작동되는지도 모르겠습니다.
  • profile

    rx_encoded_properties=""로 나오는 것은 에디터 컴포넌트에서 사용하는 비표준 속성들(multimedia_src 등)을 별도로 모아 필터링하는 과정에서 에러가 발생한 것입니다. 다른 사이트에서는 잘 되는 것으로 보아 특정 서버 환경에서만 발생하는 문제인 듯 하며, 좀더 자세한 테스트가 필요할 것 같습니다. 쪽지 드릴게요.

  • profile profile
    답장 드렸습니다!
  • profile profile
    우분투 14.04의 고질적인 버그 때문에 mcrypt 모듈이 제대로 설치되지 않아 HTML 필터링을 비롯한 보안 관련 함수들이 오류를 뿜고 있었습니다. 수정해 드렸습니다.
  • profile profile
    감사합니다!! 기진곰님 덕분에 정상적으로 동작됨을 확인하였습니다!