질문/조언질답게시판

안녕하세요.

 

문의드립니다.

 

1)우선적으로 글쓰기 부분에서 글등록시 , 새로고침이 목록으로 돌아가지않고 에디터에 유지되면서

 

아무런 반응이 없는데요.

 

막상 목록에 들어가면 작성이 되어있네요.

 

예전에는 쇼핑몰 모듈이 있어서 그부분 삭제로 해결을 했었는데 따로 최근 설치한 애드온이나 이런부분이

 

없어 충돌되는 부분은 다 꺼보고 진행을 해본 상태거든요.

 

콘솔창에는 Detecting changes using MutationObservers 에러가 뜨고있는데 . 

 

ckeditor.js:902 이쪽에서 에러가 나네요.,,

 

#추가적으로 모든 애드온 끄기, 캐시파일 재생성, 레이아웃 사용 해제 등 여부는 다 확인해본 상태입니다.

 

2) 관리자 메뉴 캐시파일 재생성 및 세션 정리시 오류

 

The result is not valid XML          xe.min.js:7

 

이 에러가 콘솔창에 뜨면서 수정했습니다라는 메세지 박스는 뜨지않고 콘솔창에만 뜨며 반응이 없네요.

 

해당 문제를 겪어보신 분이나 해결해보신분들 답변좀 부탁드리겠습니다.

 

자세한 내용을 위해 서버 환경 적어드립니다.

 

[XE Server Environment 2017-04-04]

realpath : /var/www/html
location : ko
package : XE
app : Apache/2.2.15 (CentOS)
xe_version : 1.8.29
php : 5.3.3
db_type : mysql
use_rewrite : Y
use_db_session : N
use_ssl : none
phpext : core, ereg, libxml, openssl, zlib, bz2, calendar, ftp, gettext, gmp, iconv, shmop, simplexml, sockets, exif, xml, curl, fileinfo, gd, mbstring, mysql, mysqli, pdo_mysql, pdo_sqlite, phar, sqlite3, zip
module : adminlogging(1.7), board(1.7.2), contact(1.7.0.2), faq(1.7.0.1), krzip(1.8.0), seo(1.8.19), sitemaplite(1.1.1), stats(1.1.1), syndication(5.0.0)
addon : adminlogging(1.7), captcha_member(1.7), oembed(1.0), stats(1.1)
layout : doorweb_v4(1.7), xe_official(1.7), xedition(1.9), user_layout(1.7)
widget : counter_status(1.7)
widgetstyle : simple(1.7)
max_file_uploads : 20
post_max_size : 8M
memory_limit : 128M
 

  • profile

    Detecting changes using MutationObservers는 오류가 아니라 그냥 정보성 메시지입니다. 콘솔에 나오는 것이 모두 오류는 아니니, 색깔별로 잘 구분하시기 바랍니다.

     

    글은 작성이 되는데 글읽기 화면으로 넘어가지 않는 것은 글 등록 과정에서 뭔가 에러가 발생하고 있다는 뜻입니다. 콘솔창을 보실 수 있다면 그 옆에 네트워크 탭도 보실 수 있을 테니, 글을 등록하는 AJAX 요청에서 응답 코드와 응답 내용이 어떻게 돌아오는지 확인해 보세요.

  • profile ?
    아아 정보성 메세지였군요. 착각했네요.. 나머지는 200으로 정상으로 뜨고있고, css나 jquery부분, handlerbars.min.js 이러부분들은 304로 뜨고있네용..
  • ? profile
    그거 말고 글 등록하는 순간에 발생하는 POST 요청을 자세히 살펴보세요. 코드뿐만 아니라 응답 내용(response)도 봐야 합니다.
  • profile ?
    response 내용은

    <?xml version="1.0" encoding="UTF-8"?>
    <response>
    <error>0</error>
    <message>등록했습니다.</message>
    <mid><![CDATA[review]]></mid>
    <document_srl>2844</document_srl>
    <message_type></message_type>
    </response>

    이렇게뜨고.. 뭔가 잘못된걸까요.. The result is not valid XML 이문구가 글쓰기 창에도 뜨네요..
  • ? profile
    XML 앞에 UTF-8 BOM이 들어갔다거나... 에러 메시지가 붙었다거나... 아무튼 그냥 보기에는 정상인 것 같지만 정상적인 XML로 인식하지 못하도록 하는 뭔가가 끼어든 모양입니다. 메모장으로 PHP 파일을 수정하면 UTF-8 BOM이 붙는 것이 가장 일반적인 원인입니다.
  • profile ?
    우선 답변 너무 감사드립니다.
    변경된 부분을 찾아봐야겠네요..!