엔플린트에서 제일 싼 플랜을 사용하고 있습니다.

그러다 iwinv에 관심이 생겨 Linux 64Bit / Apache 2 / UTF-8 / PHP 7.0 / MariaDB 10.x  서버로 통채 이사를 결정하였는데 계속 문제가 생기네요.

 

Call to undefined function mysql_connect() in /home1/signifie/public_html/xe/classes/db/DBMysql.class.php:76 Stack trace: #0 /home1/signifie/public_html/xe/classes/db/DB.class.php(1288): DBMysql->__connect(Array) #1 /home1/signifie/public_html/xe/classes/db/DBMysql.class.php(49): DB->_connect() #2 /home1/signifie/public_html/xe/classes/db/DBMysql.class.php(58): DBMysql->DBMysql() #3 /home1/signifie/public_html/xe/classes/db/DB.class.php(168): DBMysql::create() #4 /home1/signifie/public_html/xe/config/func.inc.php(205): DB::getInstance() #5 /home1/signifie/public_html/xe/modules/session/session.model.php(29): executeQuery('session.getSess...', Object(stdClass), Array) #6 [internal function]: sessionModel->read('78cvbmn4mri6ljp...') #7 /home1/signifie/public_html/xe/classes/context/Context.class.php(345): session_start() #8 /home1/signifie/public_html/xe/index.php(46): Context->init() #9 {main} thrown in

 

이라는 메시지가 뜹니다.

db config 파일에서 mysqli로 변경하니 아예 깨져나오고 gb_handler를 꺼도 계속 깨집니다.

db만 놔두고 파일만 새로 깔 때는 또 이상이 없습니다. 도대체 왜 그런 걸까요? 해결방법이 있는 걸까요?

결국 화가 나서 계정 초기화했습니다.

  • ?
    현재 스펙은 php 5.5.23/mysql 5.1.58입니다.
  • profile

    호스팅 이용자라 자세히는 모르겠지만, php5.6에서
    php7 으로 iwinv 로 이전할 때, 오류가 나서 두가지를 수정해줬더니 해결되었습니다.

    첫번째는 iwinv 에 들어가서 제 계정의 웹 방화벽 설정을 꺼주었고,
    두번째는 아래 링크대로 수정해 줬습니다.

    https://xetown.com/lakepark/484394#comment_512674

  • profile ?
    둘 다 했지만 모두 실패했습니다.
  • profile

     iwinv Linux 64Bit / Apache 2 / UTF-8 / PHP 7.0 / MariaDB 10.x  
    xe는 모르겠군 라이믹스 설치했는 데. 파이어폭스,웨일 브라우저에서 백지현상 일어나더라구요.
    서버의 셋팅이 문제가 있는지도 모르겠네요

  • profile ?
    아무래도 가격 때문인지도 모르겠네요 아니면 초창기라 그런가...
  • profile
    mysql_connect 함수자체가 사용이 안되는듯 보이는데요.
    mysqli_connect로 치환변경하시거나 아니면설정쪽을 찾아보시는걸 권장드립니다
  • ?
    php 5.5.23 -> php 7.0 으로 변경되었을때 변경되는 함수부분 확인해야될거 같구요..아니면 기존 버전(5.5.23) 하고 동일하게 설치하고 확인해보심이...
  • ?

    구글링좀 해보니....이정도 나오네요.

    http://stackoverflow.com/questions/35424982/how-to-enable-mysqli-extension-in-php-7

    번역 "PHP7에서는 mysqli 기능이 default 값은 disable 이니...사용하려면 주석을 해제하라"
    경로 : /etc/php/7.0/apache2/php.ini (경로는 설치방법에 따라 달라질수 있습니다.)
    extension=php_mysqli.so

     

    아니면... 

    php -i|grep configure  확인해서.. mysqli 설치여부 확인해보시구요...