제 wordpress 사이트에 nextend social login 이라는 플러그인을 설치하고 사용하려 합니다. 

 

그런데 구글 인증 단계에서 오류에 부딪혀 나아가지 못하고 있습니다. 

image.png

여기서 인증을 시도하면,

image.png

이 문제에 부딪힙니다. 

 

일단 이 문제 해결을 위해 플러그인 제작팀에 문의했고 다음의 답을 이메일로 받았습니다.

 

=============================================================

 

웹 사이트의 문제는 특정 문자열, 특히 ".profile"이 포함 된 요청을 차단하는 방화벽 (아마도 ModSecurity )으로 인해 발생합니다.

 

ModSecurity를 사용하면 블랙리스트에이 문자열이 있지만 Google에서 사용하는 범위 중 하나이기 때문에 실제로 매우 일반적인 문제입니다.

 

또한 Google의 OAuth 요청이 차단됨을 의미하는 ".profile" 문자열이 포함되어 있습니다.

 

실제로 Nextend Social Login이 없어도 이 문제를 쉽게 재현할 수 있습니다. GET 매개 변수 값에 .profile 문자열이 나타나는 /wp-login.php 페이지를 열기만 하면 됩니다.

 

요청이 차단되고 403 오류가 반환됩니다. 그러나 블랙리스트에 오른 ".profile"문자열을 더 이상 포함하지 않으면 마지막 "e"문자를 제거합니다. 그러면 /wp-login.php 페이지가 잘로드됩니다.

따라서 문제를 해결하려면 호스트에 연락하여 문제를 일으키는 규칙을 비활성화하도록 요청해야 합니다. 방화벽에 의해 트리거된 오류 메시지를 포함하여 모든 종류의 오류 메시지가 포함된 오류 로그가 있습니다. 그리고 여기에는 이 403 오류를 일으키는 규칙 ID가 포함되어야 합니다.

 

해당 규칙이 제거되면 문제가 더 이상 발생하지 않습니다.

 

==============================================

 

제가 이해한 내용은, modsecurity 라는 보안 영역에서 특정 규칙을 비활성화, 즉 블랙리스트에서 해제해야 한다는

것입니다.

 

그런데 메일에서 웹호스팅관리자에 해당 내용을 요청해서 처리하라고 했기에, 

 

제가 사용하고 있는 벌쳐에 문의 했습니다.

 

그런데 벌쳐에서는 방화벽 관련 내용은 본인들의 소관이 아니라 도와줄 수 없다고 합니다. 

 

=========================================================

 

현재 저는 openlightspeed 서버 시스템을 사용하고 있어서, 

CyberPanel 관리창에서 

 

image.png

다음의 메뉴에서 나름 해결책을 찾아보려 해보았습니다. 

 

혹시 

image.png

이 단계에서 제가 인증 오류를 해결할 수 있을까요?

 

===================================================

image.png

여기에서 룰을 추가하거나, 

 

image.png

이 메뉴에서 

image.png

이런 메뉴들을 조정해서 말이죠

 

식자님의 고견 기다립니다..