Extra Form
PHP PHP 7.2
CMS Rhymix 2.1

1. 현재 가상서버 환경

[Basic Information] rhymix_version : 2.1.15 date : 2024-06-18 14:15:00 +0900 (2024-06-18 05:15:00 UTC) php : 7.2.33-1+ubuntu18.04.1+deb.sury.org+1 (64-bit) server : nginx/1.19.0 os : Linux 4.15.0-117-generic

 

2. xe푸시앱 업그레이드 ( https://xetown.com/thirdpartynews/1827857 )를 위해 급하게 php버젼을 7.2에서 7.4로 업그레이드를 해야 할 상황입니다.

 

3.  php 7.2에서 7.4 업그레이드를 위해서는 현재 오래된 우분투 18.04를 우선 업그레이드를 하고 자동 설치된 php7.4를 이용해야 할 상황인 건 알고 있는데요.  ( 조만간 운영체제 업그레이드 예정 입니다 )

 

우선 임시로 현 우분투 18.04 / php7.2  에서 php7.4로 업그레이드가 아예 근본적으로 안되는 부분인건지 아니면 예상되는 문제점이 어떤게 있을까요?

 

4. 만약 우분투 18.04 / php7.2에서 php7.4로 업그레이드해도 별 문제가 없다면 아래 쳇 gpt의 답변대로 진행하면 될까요?

screencapture-chatgpt-c-aee5c2d6-e39c-48d3-b558-dc56336bcf81-2024-06-18-14_11_07.jpg

  • profile

    ondrej/php 저장소는 우분투 18.04 지원을 끊은 지 한참 됐습니다.

    최신 OS에 오래된 PHP를 설치하는 방법은 많지만,

    오래된 OS는 국물도 없다는 것이 오픈소스계의 국룰이죠.

  • profile ?
    답변감사합니다.