Extra Form
PHP PHP 7.4
CMS Rhymix 2.0

서버 세팅할 때 MariaDB 버전은 어떤 걸로 하시나요?

많은 경우 10.2나 4 버전이 깔리는 거 같은데

이걸 10.9나 8로 깔라도 특별히 문제 없을까요?

아니면 무조건 최신이 좋은 걸까요?

 

  • profile

    장기간 지원을 보장하는 안정화 버전과, 단기간 개발하다가 폐기하는 실험적인 버전을 구분하셔야 합니다. MariaDB의 최신 안정화 버전은 10.6이고, 10.7 이상은 모두 1년짜리 시한부 인생이예요. 버그나 보안취약점이 발견되더라도 패치하지 않고 그냥 폐기할 예정이라는 뜻이지요. 여러 가지 실험을 해보다가 좀 안정화됐다 싶으면 또다시 안정화 버전을 내놓겠지만, 아무튼 현 시점에 10.7 이상은 거들떠볼 필요가 없어요.

     

    센토스, 우분투 등의 운영체제에서 기본 제공하는 버전은 조금 더 오래된 안정화 버전일 가능성이 높습니다. 새 버전에서 추가된 A, B, C 기능이 나는 꼭 필요하다! 라고 생각하신다면 몰라도, 일반적인 블로그나 커뮤니티 사이트 운영 목적으로는 눈에 띄는 차이가 없으니 장기간 보안패치가 보장되는 버전이 장땡이예요.

  • profile
    역시나 그렇군요
    경험에서 우러나오는 답변 감사합니다
    10.5나 10.6으로 가야겠네요 ^^