Extra Form
PHP PHP 7.2
CMS 기타

Information of the plugin that should be installed:
Google Analytics - xpressengine-plugin/google_analytics:1.0.3

Clears the cache before the operation run.
Cache cleared successfully. XE cache has also been cleared.


Composer update command is running.. It may take up to a few minutes.
composer update --with-dependencies xpressengine-plugin/google_analytics
Checking file permission:
/home/ubuntu/storage/app/composer.plugins.json - passed
/home/ubuntu/storage/app/operations.json - passed
/home/ubuntu/composer.lock - passed
/home/ubuntu/plugins/ - passed
/home/ubuntu/vendor/ - passed
/home/ubuntu/vendor/composer/installed.json - passed

Checking COMPOSER_HOME environment variable:
passed
GC collected cycles: 0
> Xpressengine\Plugin\Composer\Composer::command
> Xpressengine\Plugin\Composer\Composer::preUpdateOrInstall
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Info from https://repo.packagist.org:  [37;44m#StandWith [30;43mUkraine [0m
Updating dependencies (including require-dev)

 

물어볼곳도 없고 하다보니 이렇게 질문드리게 되었습니다 ㅠㅠ

XE3 설치 후 익스텐션 설치 부분에서 해결이 안되고 있습니다..

AWS Lightsail로 설치했는데 도통 원활하게 설치가 안되서 곤욕중입니다. ㅠ

 

내용을 보아하니 컴포저 1버전을 사용할수 없으니 2버전으로 업그레이드 하라는걸까요?

sudo composer self-update 하고 2.3.5로 올린 상태에서 하면 "시스템에 오류가 있습니다. 관리자에게 문의하세요."라고 뜨고, composer upgrade라고 하면 

 

Cannot create cache directory /home/ubuntu/.cache/composer/repo/https---store.xehub.io/, or directory is not writable. Proceeding without cache
Cannot create cache directory /home/ubuntu/.cache/composer/repo/https---repo.packagist.org/, or directory is not writable. Proceeding without cache
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires wikimedia/composer-merge-plugin 1.3.1 -> satisfiable by wikimedia/composer-merge-plugin[v1.3.1].
    - wikimedia/composer-merge-plugin v1.3.1 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.3.0] but it does not match the constraint.
  Problem 2
    - Root composer.json requires xpressengine/installer ~1.1.1 -> satisfiable by xpressengine/installer[1.1.1, 1.1.2].
    - xpressengine/installer[1.1.1, ..., 1.1.2] require composer-plugin-api 1.1.* -> found composer-plugin-api[2.3.0] but it does not match the constraint.


라고 뜹니다;;

 

계속 반복이에요.. xe 가이드처럼 $ sudo composer self-update 1.8.6했다가 2.3.5로 올렸다가 XE는 문의해도 답도없고 ㅠㅠ

답답하네요;

 

  • profile
    워닝은 가볍게 생각하고 넘겨두 될 애러같은데.. 다른 에러메세지는 안드던가요?

    failed 난 부분이 없는지 다시 한번 에러로그를 살펴보세요.

    근데.. 굳이 XE3를 쓰시지 않으실꺼라면 저는 xe3로 작업하기보단 그냥 다른 CMS를 추천합니다.

    컴포저 사용하는거 자체가 일반사람들에게 까다로운데.. 웹호스팅환경에서도 사용이 가능한 것으로 작업해도 크게 무리가 없을텐데 굳이 사서 고생하실 필요는 없을거거든요..

    xe3로 하신다면 앞으로도 좀 고생길이 보이실겁니다..
  • profile ?
    조언 감사합니다ㅠ 초보이다 보니 xe3는 제가 해결해야할 과제들이 너무 많네요... 라이믹스는 쉽게 설치가 되서 아무래도 라이믹스로 가야될거같습니다 ㅠ
  • profile
    XE3은 컴포저 2를 지원하지 않습니다. 컴포저 1버전 사용하시는게 맞습니다.

    쉬운 해결방법으로 XE3을 지우고 https://rhymix.org/ 라이믹스 설치해서 사용하시는 방법이 있습니다. XE3보다 훨씬 폭넓고 다양한 자료를 사용할수 있습니다.
  • profile ?
    지난번에도 도움주셔서 감사합니다. 아무래도 말씀대로 라이믹스로 가는것이 제가 오래살 길인것 같습니다..