Information of the plugin that should be installed:
Google Analytics - xpressengine-plugin/google_analytics:1.0.3
Clears the cache before the operation run.
Cache cleared successfully. XE cache has also been cleared.
Composer update command is running.. It may take up to a few minutes.
composer update --with-dependencies xpressengine-plugin/google_analytics
Checking file permission:
/home/ubuntu/storage/app/composer.plugins.json - passed
/home/ubuntu/storage/app/operations.json - passed
/home/ubuntu/composer.lock - passed
/home/ubuntu/plugins/ - passed
/home/ubuntu/vendor/ - passed
/home/ubuntu/vendor/composer/installed.json - passed
Checking COMPOSER_HOME environment variable:
GC collected cycles: 0
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Info from https://repo.packagist.org: [37;44m#StandWith [30;43mUkraine [0m
Updating dependencies (including require-dev)
물어볼곳도 없고 하다보니 이렇게 질문드리게 되었습니다 ㅠㅠ
XE3 설치 후 익스텐션 설치 부분에서 해결이 안되고 있습니다..
AWS Lightsail로 설치했는데 도통 원활하게 설치가 안되서 곤욕중입니다. ㅠ
내용을 보아하니 컴포저 1버전을 사용할수 없으니 2버전으로 업그레이드 하라는걸까요?
sudo composer self-update 하고 2.3.5로 올린 상태에서 하면 "시스템에 오류가 있습니다. 관리자에게 문의하세요."라고 뜨고, composer upgrade라고 하면
Cannot create cache directory /home/ubuntu/.cache/composer/repo/https---store.xehub.io/, or directory is not writable. Proceeding without cache
Cannot create cache directory /home/ubuntu/.cache/composer/repo/https---repo.packagist.org/, or directory is not writable. Proceeding without cache
Info from https://repo.packagist.org: #StandWithUkraine
Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires wikimedia/composer-merge-plugin 1.3.1 -> satisfiable by wikimedia/composer-merge-plugin[v1.3.1].
- wikimedia/composer-merge-plugin v1.3.1 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.3.0] but it does not match the constraint.
- Root composer.json requires xpressengine/installer ~1.1.1 -> satisfiable by xpressengine/installer[1.1.1, 1.1.2].
- xpressengine/installer[1.1.1, ..., 1.1.2] require composer-plugin-api 1.1.* -> found composer-plugin-api[2.3.0] but it does not match the constraint.
계속 반복이에요.. xe 가이드처럼 $ sudo composer self-update 1.8.6했다가 2.3.5로 올렸다가 XE는 문의해도 답도없고 ㅠㅠ