질문/조언질답게시판

 Context::unloadJsFile('/common/js/jquery-2.2.4.min.js');

 

 classes/display/HTMLDisplayHandler.php 

$jquery_version = preg_match('/MSIE [5-8]\./', $_SERVER['HTTP_USER_AGENT']) ? self::JQUERY_V1 : self::JQUERY_V2;

 

해당 소스를 찾아 볼수 있었는데요 혹시 선택적으로 JQuery 를 선택할 수 있는 방법 알고 계시면 방법좀 부탁드립니다. 

 

  • profile

    https://github.com/rhymix/rhymix/pull/1053#issuecomment-410532987

     

    라이믹스에서는 해당 부분 언로드같은 기능을 제공하지 않고, 굳이 jQuery 버전을 변경하고 싶으시다면 그건 사용자가 직접 변경하고 라이믹스팀에서는 거기에 대해서 책임을 지지 않습니다.;ㅁ;

     

  • profile
    배포용 자료가 아닌 혼자 사용하시려는 경우 그냥 jquery 파일을 원하시는 버전으로 덮어씌우시면 됩니다. 물론 추후 업데이트시 매번 재적용이 필요하겠죠.

    다만 jquery 언로드는 지원하지 않습니다. 코어에 jquery에 의존하는 코드가 있어 무작정 제거해버리면 일부 기능이 오동작하게 됩니다.
  • profile
    감사합니다 ^^
    해당 부분에 분기 하는 부분이 있어서 혹시 어디 설정 하는 부분이 있을까 싶었습니다.
    답변 달아주신 모든 분들 감사드립니다~