Extra Form
PHP PHP 7.4
CMS Rhymix 2.x

 

현재 오라클클라우드 무료 티어 서비스를 사용하고 있습니다.

 

초기 세팅 당시 보고 따라하던 사이트가 php 7.4 기준으로 설명이 되어 있었는데 

 

당시에 php 8.0으로 응용해 보려고 설치 했다가 잘 안되어서 삭제 명령어로 삭제 하고 

 

7.4 버전으로 재설치 해서 현재까지 사용 중입니다. 

 

다만 당시에 제대로 8.0 버전이 삭제가 되지 않았거나 실수로 재설치가 된것인지 

 

현재 버전을 찍어보면 이렇게 나오네요.

 

리눅스에서 php 버전 체크 

[email protected]:/$ php -v
PHP 8.0.3 (cli) (built: Mar  5 2021 07:53:56) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.3, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.3, Copyright (c), by Zend Technologies

 

그리고 설치된 환경은 이렇게 나옵니다.

 

라이믹스 설치 환경 

[Basic Information]
rhymix_version : 2.0.11
date : 2021-05-09 15:32:36 +0900 (2021-05-09 06:32:36 UTC)
php : 7.4.16 (64-bit)
server : nginx/1.14.0
os : Linux 5.4.0-1038-oracle
sapi : fpm-fcgi


미디어 위키 설치 환경

설치된 소프트웨어
제품    버전
MediaWiki    1.35.2
PHP    7.4.16 (fpm-fcgi)
MariaDB    10.5.9-MariaDB-1:10.5.9+maria~bionic

 

 

라이믹스 하위 폴더에 미디어 위키를 설치해서 사용중인데 가끔 데이터 오류가 발생해서 검색해 보면

설치한 미디어 위키 버전에서는 php 7.43 이상의 버전을 권장해서 php 업데이트를 실행 하려다 발견한 문제인데

이렇게 사용해도 큰 문제가 없는것인지 8.0을 삭제해 줘야 할지 판단이 서지 않아서 조언을 구하고 싶습니다. 

 

 

 

  • profile

    제대로 삭제되지 않고 두 버전이 뒤섞여 있는 상태라면 언젠가는 문제를 일으킬 수 있습니다. 우분투라면 apt remove php8.0-* 명령으로 남은 찌꺼기를 모두 제거할 수 있을 거예요.

  • profile profile

    감사 합니다 기진곰님 덕분에 정상 출력 됩니다.

     

    [email protected]:/$ php -v

    PHP 7.4.16 (cli) (built: Mar  5 2021 07:54:20) ( NTS )

    Copyright (c) The PHP Group

    Zend Engine v3.4.0, Copyright (c) Zend Technologies

        with Zend OPcache v7.4.16, Copyright (c), by Zend Technologies