질문/조언질답게시판

보안패치 문의

Extra Form
PHP PHP 7.3
CMS Rhymix 2.x

문의 드립니다.

 

만약 1.9.10 버전으로 설치하고 2.0.10 버전으로 전부 업데이트(다운로드 페이지의 왼쪽 빨간 버튼)하면

문제 되는 부분이 있을까요?

 

2.0.11 버전 업데이트 할 때 Changed Files Only(다운로드 페이지의 오른쪽 회색 버튼)으로 하면

권장하지 않는다고 떠서 패치 파일로 하면 어떤 점에서 비권장하는지 궁금합니다.

 

(현재 라이믹스 버전을 FTP 에서 알 수 있는 파일이 있을까요?)

  • profile

    1.9.X에서 2.0.X로 가려면 전체 업데이트가 안전합니다.

     

    현재 버전은 common/constants.php 파일에 있고, 관리자 화면 하단에도 나옵니다.

     

    변경분 파일은 동일 계열의 직전 버전에서 업데이트하는 경우에만 사용할 수 있습니다. (예: 1.9.10 → 1.9.11) 만약 5개의 버전을 한 번에 건너뛴다면 각각의 변경분 파일을 일일이 다운받아서 순서대로 적용해야 하니, 전체 업데이트하는 것보다 오히려 더 불편할 것입니다.

     

    직전 버전이 아닌데 이 방법으로 업데이트하려고 하다가 이 버전도 저 버전도 아닌 프랑켄슈타인 상태가 되어 버리거나, 코어를 임의로 수정해 놓은 부분이 덮어씌워지는 것을 회피하는 수단으로 변경분 파일을 사용하는 사례가 많기 때문에, Changed Files Only는 공식적으로 권장하지 않는 것입니다.

     

    코어를 수정해 놓은 부분이 없다면 언제든지 전체 업데이트를 해도 괜찮습니다. 라이믹스는 코어를 수정한 채 업데이트하기가 XE나 그누보드보다 훨씬 어렵습니다. 대규모의 변화가 자주 일어나고, 많은 파일을 일괄적으로 수정하는 일이 많으므로 언제 어떤 파일이 크게 바뀔지 모릅니다. 수시로 파일을 갈아엎고 심지어 운영자가 자는 사이에 스스로 전체 업데이트를 해버리는 워드프레스에 더 가깝다고 볼 수 있겠습니다. 그래서 git 등의 전문적인 도구로 코어 수정 내역을 관리할 수 있는 개발자가 아니라면 코어를 수정해서 쓰는 것을 강력히 비추하고, 코어 수정을 유도하는 팁글에도 개발팀이 어김없이 반대 의견과 적절한 대안을 남기고 있으며, 수정이 꼭 필요하다면 혼자서만 고쳐쓰지 말고 코어에 정식으로 반영을 요청하도록 권유하고 있습니다.