질문/조언질답게시판
Extra Form
PHP PHP 7.3
CMS Rhymix 2.x

안녕하세요.

라이믹스 2.0.8로 

테스트용 사이트를 하나 세팅하려는데요.

호스팅 회사사 서버가

PHP7.0 / PHP7.3 중 선택하라고하는데

뭘 선택하면 되는지 모르겠습니다. ㅠㅠ

 

라이믹스 2.0.8은 git에서 다운받았어요.

 

 

  • ?
    7.3 버전을 권장합니다.

    라이믹스 팀에서 2021년 하반기부터 최소사양을 7.2 이상으로 올린다고 공지했기 때문입니다. ( https://www.github.com/rhymix/rhymix-docs/tree/master/ko%2Fintroduction%2Frequirements.md )

    다만 7.2 버전 이상에서 일부 모듈/애드온에 있는 Object 문제가 발생할 경우, Base Object로 바꾸는 작업을 하셔야 합니다. ( https://www.gaonwiki.com/w/라이믹스/사양#7.2_이상 문서 참고)
  • profile

    2021년 3월 현재 가장 안정적인 버전은 7.4라고 생각합니다. 7.4가 없다면 7.3이라도 괜찮습니다.

    7.2도 아직은 쓸만하지만, 그 밑으로는 올해 안에 라이믹스에서 지원을 중단할 예정이고

    7.2에서도 앞으로 추가되는 새 기능들은 작동 안 할 가능성이 높으니 최소 7.3을 추천합니다.

  • profile
    어디선가 듣기론 홀수 버전보단 짝수 버전이 안정적이고 좋다고 들었습니다.
  • profile profile

    PHP 버전은 홀수/짝수 무관 모두 안정 버전입니다. 홀/짝 법칙 자체가 요즘은 잘 쓰이지 않으므로(그걸 쓰던 대표적인게 리눅스 커널인데 3.0 버전부터 홀/짝 버전을 폐지했습니다. https://allthatlinux.com/dokuwiki/doku.php/linux_version_rule) 신경쓰지 않으셔도 됩니다. 오히려 우분투처럼 짝수 버전이 LTS 버전=안정 버전이고 홀수 버전이 불안정 버전인 경우도 있습니다.

  • profile profile

    공식적인 방침과 무관하게 짝수 버전이 더 안정적인 경우가 은근히 있더라구요. 예를 드신 우분투도 (모든 짝수 버전이 LTS는 아니지만) 모든 LTS는 짝수 버전이고, PHP 7.1은 좀 불안정했던 기억이 있고, MySQL 5.7에서 호환성 깨진 것이 많고...

  • profile
    현재 라이믹스next 브랜치에 추가된 소셜로그인에서 일부 서비스 (트위터 애플 등등)는 PHP7.3 이상 필요합니다..ㅋㅋ 이러한 기능들의 영향이 있으므로 올릴 수 있을때 최소 7.3이상으로 올리시는것이 좋죠 ㅎㅎ