질문/조언질답게시판

라이믹스가 2.0으로 오면서 아마 $db_info 라는 변수 자체가 없어진 것 같은데요..

그래서인지 어떻게 해도 이 옵션을 활성화시킬 수가 없네요.

이 옵션을 사용하는 방법이 있을까요?

저는 현재 apc 캐쉬를 사용하고 있습니다.

  • profile
    설명에 $db_info 라고 적힌건 XE설정의 기준으로 만들어둔것이지 그것과는 상관없습니다.

    실제 라이믹스에서 고급설정-> 캐시설정을 재대로 설정하셨고 정상적으로 작동된다면 해당 설정을 킬 수 있습니다.
  • profile ?

    Context::getDBInfo()의 결과가 다음과 같이 나오고 있습니다.
    (캐쉬 관련해서는 apc로 정상적으로 설정이 되어 있는 상태입니다)
    stdClass Object ( [master_db] => Array ( [db_type] => mysql [db_hostname] => localhost [db_port] => 3306 [db_userid] => phpmyadmin [db_password] => ******** [db_database] => ggchat [db_table_prefix] => rx_ [db_charset] => utf8mb4 ) [default_url] => http://ggchat.net/ [http_port] => [https_port] => [use_ssl] => none [lang_type] => ko )
    캐쉬 관련한 설정이 아예 안보이는 것 같습니다...

  • ? profile
    당연히 그거랑 상관없어요...
  • profile ?
    parselink.admin.view.php 23라인에
    Context::set('object_cache_available', preg_match('/^(apc|file|memcache|redis|wincache|xcache|sqlite)/', Context::getDBInfo()->use_object_cache));

    이렇게 해서 $object_cache_available를 설정하고
    관리페이지 템플릿에 보면

    <select name="use_cache" disabled="disabled"|cond="!$object_cache_available || $config->use_db_data !== 'yes'">

    $object_cache_available를 참고해서 disabled로 만드는 것 같습니다.
  • ? profile
    debugPrint(Context::getDBInfo()->use_object_cache);

    찍어보세요.