질문/조언질답게시판
Extra Form
PHP PHP 5.x
CMS XpressEngine

현재 조그만 개인홈페이지를 XE 1.5.4.3으로 만들어 사용하고 있는데요.

개인적으로 그럭저럭 만족하며 사용해왔는데 게시판의 파일 업로드 방식이 플래쉬를 사용하는데 어도비사에서 플래쉬를 더이상 업데이트 안하겠다고 하고 브라우저에서도 곧 지원을 안하겠다고해서 구버전 XE를 다른걸로 바꿔야 할것 같아서 알아보다 라이믹스를 알게되었는데 라이믹스로 갈아탈경우 질문 드립니다.

 

검색해보니 구버전 XE를 라이믹스로 갈아탈경우 XE 1.9까지 업데이트하고나서 라이믹스로 덮어쓰라고 되어있는데 이용하고있는 카페24 웹호스팅 php 버전이 5.2인데 이걸 그대로 두고 XE1.9까지 업데이트하고 라이믹스로 덮어쓸때 PHP 7.0으로 바꾸고 해야하는지 아니면 XE로 업데이트하는 중간에 PHP를 5.5.나 7.0으로 바꾸고 업데이트를 해야한다면 XE 어느버전부터 PHP 버전을 바꾸고 업데이트를 진행해야 하는지 모르겠어서 질문드립니다.

 

XE 1.5.4.3 나름 만족해왔는데 좀 아쉽네요...-_-

  • profile

    PHP 5.2에서는 XE 1.9도 안 돌아갑니다. PHP부터 바꾸셔야 할 것 같네요.

  • profile ?

    어느버전부터 php버전을 바꿔야 하나요?..xe 1.8로 업데이트 할때부터 php 5.5로 바꾸고 xe 1.9업데이트하고나서 php7.0으로 바꾸고 라이믹스로 덮어쓰면 될까요?

  • ? profile
    php5.3이시라면 xe 1.7.5 부터 업데이트 하시고 -> xe1.8 -> 1.11.6 단계로 최신버전까지 업데이트 하시면 됩니다.

    그런다음 PHP7.0으로 변경이후 라이믹스 설치하시면 됩니다.

    일부 호스팅에서는 PHP버전 변경시 사이트 이전 작업이 필요합니다.
  • profile ?
    php 5.2인데 알려주신 방법으로 해도 될까요?..
  • ? profile
    php5.2라면 최소지원이 어려우니 1.7버전에서 PHP버전을 한번 php5.3 ~ 5.6사이 업데이트 하시고요 그다음에 순차적으로 xe를 1.8, 1.9 1.11.6 으로 업데이트 마친다음 PHP7.0버전으로 업데이트 하신다음 라이믹스 업데이트 하시면됩니다.
  • ? profile

    XE 1.9는 PHP 7.0에서 정상 작동하니, PHP 버전은 한 번만 바꾸셔도 됩니다. 중간에 1.7을 거칠 필요도 없습니다.

    만약 문제가 발생한다면 추가로 설치하신 모듈, 애드온, 스킨 등이 원인일 가능성이 높습니다.

  • profile ?
    답변 감사합니다.
  • profile ?
    답변 감사합니다.