질문/조언질답게시판
Extra Form
PHP PHP 5.3
CMS XpressEngine

현재 회사에서 사용하고 있는 사이트의 xe버전이 1.4.5.7 , php5.2.17 입니다.

 

플래쉬 종료 문제(파일첨부 및 기타 ..)로 코어 업데이트를 해야될 것 같은데 , 버전이 너무 옛 버전이라 

 

좋은 방법이 있나 여쭙고 싶습니다 ㅠㅠ..

 

 

 

(ckeditor사용하려면 1.8이상이라고 들었습니다)

  • profile
    1. 일단 금전적으로 아무것도 안들이고 하는 방법은 레이아웃을 변경하는 것입니다.

    https://xe1.xpressengine.com/downloads 에서 심플하고 옜날에 올라온 자료들중 하나로 레이아웃을 바꾼다면 기본 플레시기반의 레이아웃에서 벗어나므로 플래시정도는 벗어날 순 잇습니다. 그에 따라 디자인이나 게시판 스킨을 변경하는등의 추가적인 작업이 필요하지만 가장 리스크가 적고 가장 저렴하게 조치가 가능합니다.

    2. 업데이트를 하시기엔 너무 낮은 버전입니다. 1.4 버전대의 경우 1.5, 1.7, 1.8 최신으로 단계단계로 업데이트를 진행하셔야 합니다.

    특히 1.4버전에서 1.5버전으로 올리실 경우 공사중모듈이나 혹은 아무도 접속하지 않도록 미리 조치를 취한다음 업데이트를 진행해야 정상적으로 되는만큼 난이도가 극상이 됩니다. 따라서 전문적으로 업데이트를 해주시는 곳에 의뢰를 맡기시는편이 좀 더 나을지도 모릅니다.
  • profile ?
    안녕하세요 람보님 친절한 답변감사합니다.

    1번 부터 시도해보고 안되면 업데이트 의뢰를 맡겨야겠네요 ㅠㅠ.. 감사합니다
  • profile ?
    한가지 더 질문드려도 될까요 ?
    회사 사이트 레이아웃에 보면 다 커스텀으로 만든것 같은데 이런경우에는 어떻게 하는게 좋을까요?
  • ? profile
    어떤걸 커스텀으로 다 만든것인지 모르겟지만 커스텀으로 만든항목들이 만약 에러가 난다면 결국 에러로그나 이런쪽에 다 남게 되겟죠.
    만야 거기에서 에러난다면 어떻게 하냐는 질문이라면 그건 거기에 따라 처음부터 끝까지 하나하나 고쳐야죠 ㅎㅎ 작동이 잘될때까지요 ㅎㅎ
  • profile ?
    넵 답변 감사합니다 람보님 :)
  • profile
    우선 현재 서버에서 XE 1.5.4.3 버전을 거쳐 1.7.13 버전까지 업데이트합니다.(PHP 5.2에서 설치 가능한 최신 버전입니다) 물론 업데이트중 오류 발생시 수정되어야 합니다.

    이후 PHP 버전을 7.0까지 업그레이드한뒤(서버 이전이나 호스팅 변경이 필요할 수 있습니다) XE 버전을 1.11.6 버전까지 업그레이드합니다. 역시 오류 발생시 수정해 주어야 합니다.

    XE 1.11.6 버전까지 업그레이드되었고 오류도 해결되었다면 라이믹스를 덮어씌웁니다. XE는 개발 중단된 CMS로 사용을 권장하지 않기 때문입니다. 역시 오류 발생시 수정해 주어야 합니다.

    이처럼 업그레이드시 오류 발생 등으로 조치가 필요할수 있으며 해결하기 까다로울수 있으니 제작의뢰 맡기시는걸 추천드립니다.

    p.s.) 레이아웃의 경우 플래시로 구성되어 있다면 타 레이아웃으로 변경하거나 제작의뢰로 HTML5 환경에 맞도록 변경할수 있습니다. 업로더의 플래시의 경우 XE 최신버전이나 라이믹스에서는 CKEditor 사용시 이미 제거되어 있습니다.