질문/조언질답게시판
Extra Form
PHP PHP 7.4
CMS Rhymix

현재 php ondrej 저장소를 이용해서 설치한 최신 php7.4.6을 이용하여 라이믹스 최신 1.9.7 master 버전을 이용중입니다.

 

큰 문제는 없지만, 자잘한 문제가 발생해서 골머리를 앓고 있네요.

게시판 모듈의 설정 부분에서 

SmartSelect_20200609-205736_Samsung Internet.jpg

위 부분이 작동하질 않습니다. ㅠㅠ

 

제가 너무 빠른 버전의 PHP 버전을 사용중임이 원인인듯 한데, 너무 빠르지도 않고 너무 구형도 아닌 안정적인 PHP 버전은 어떤 버전을 사용해야 할까요?

  • ?
    7.2 추천드립니다:)
  • profile
    제 개인서버에서 PHP7.4.5 사용중인데 라이믹스에서 게시판설정에서 질문주신것과 동일한 문제는 없습니다.

    1. PHP를 설치시 같이 설치해야하는 모듈이 누락되지 않았나요?
    2. 라이믹스의 모든파일을 서버에 업로드할때 파일자체가 누락되거나 깨진건 없던가요?
  • profile profile
    답변해주셔서 정말 감사드립니다
    서버 셋팅의 경우 라엘님의 블로그(우분투 18.04 LTS + nginx)를 그대로 따라하였고, 라이믹스 github에서 zip파일을 다웅로드받아 서버에서 unzip 명령어를 통해 압축해제 하였습니다.

    7.4.5버전에서는 정상 작동 하는군요..
  • profile profile
    php7.4.5 버전에서 버그와 보안패치를한버전이 7.4.6버전입니다. 아무래도 제가말씀드린부분 확인해보새요
  • profile profile
    필수 php 모듈이 installation 페이지에서만 통과하면 해당 부분은 만족한다는 뜻이 맞나요?
  • profile profile
    네 어느정도는 만족한다 생각하시면 되는데 해당 부분은 실제서버에서 직접디버깅 하지 않는이상 정확한 원인을 유추하기는 어렵습니다
  • profile

    PHP 7.0부터 지원한다고 되어 있기는 하지만, 7.0~7.1은 개인적으로 한동안 써본 적이 없고...

    7.3은 아래에서 말씀드릴 특정 버전대의 오류라든지, 짧은 지원기간 등 여러모로 어정쩡한 버전이라

    2020년 현재는 7.4를 주력으로, 7.2를 서브로 밀고 있습니다.

     

    7.4.5, 7.4.6 등 마지막 자리의 차이는 전혀 상관없습니다. 높을수록 버그가 줄면 줄었지 늘어나지는 않아요.

    만약 마지막 자리의 차이 때문에 문제가 발생한다고 생각하신다면 헛다리 짚고 계신 거예요.

    단, 7.3.0~7.3.1은 언어 자체의 버그 때문에 라이믹스 최신 develop 브랜치 외에는 정상 작동이 안됩니다.

    이런 특이사항은 개발팀에서 그때그때 파악하고 있습니다. 그 밖의 버전들은 문제 없습니다.

     

    말씀하신 문제는 PHP가 아니라 자바스크립트 문제일 가능성이 더 높아 보입니다.

    자바스크립트 파일이 누락되었거나, 잘못 업로드했거나, 서드파티 자료와 충돌하거나...

    애꿎은 PHP 버전 외에도 문제를 일으킬 만한 요소는 어마어마하게 많습니다.

  • profile
    브라우저가 어떻게 되시나요? 해당 영역은 디자인이 적용되지 않으면 저렇게 셀렉트 두개로 보입니다(모바일같은 경우도 동일).
  • profile
    php 7.3 이용중인데 아직까지는 문제 없었어요
    라이믹스 마스터 최신버전이에요

    서버에서 7.4로 넘어가고 싶은데 서버에서 지원해주는게 7.3이 최신이라 ㅜ
  • profile
    모바일 브라우저는 박스 선택해서 하셔야 합니다