질문/조언질답게시판
Extra Form
PHP PHP 5.6
CMS XpressEngine

Xe 1.11.5 버전 사용 중 입니다. (코어 자체수정을 많이 한 상태)

 

라이믹스로 갈아타려고 하는데.....

 

DB는 그대로 가져가도 유지되는건지 

 

첨부파일들도 그대로 유지가 될런지..

 

어떠한 방식으로 갈아타야 하는지 자세히 설명된 곳이 있을까요 ? 

 

동접자만 2000명 수준에 사이트라 .. 노트북으로 서버하나 열어서 기존 자료로 테스트 부터 해볼까 합니다.

 

설명된게 없어서.. ㅋㅋ 그냥 코어 파일만 덮어씌우면 되는건지.. ㅠㅠ

  • profile
    그냥 덮어씌우는 방식으로 전환이 가능하지만
    문제는 코어를 많이 수정하셨으면 오류가 날 가능성이 높습니다.
    테스트 할수 있는 서버가 있으면 서버에서 먼저 테스트 해보시면 될듯하네요.
  • profile profile
    답변 감사합니다.
  • ?
    코어수정 자료있으면 차근차근 라이믹스에도 적용해보고 시행하신 후

    해당 과정 다거친 파일만 덮어쓰면 쉽게 옮겨집니다.
  • ? profile
    답변 감사합니다.
  • profile

    별도 코어 수정사항이 없고, 라이믹스 최소 사양도 만족하는 경우 덮어씌우기로 바로 업그레이드할수 있습니다. 다만, 일부 서드파티 자료의 경우 수정이 필요할수 있습니다.

    하지만 PHP 버전을 5.6을 사용한다고 체크하셨고, 수정사항도 있다고 하셨으므로 바로 업그레이드하실수는 없습니다. 라이믹스는 PHP 7 버전 이상부터 지원하므로 PHP 버전도 높이셔야 라이믹스로 업그레이드하실수 있습니다.(설치만 막힌거지 사용이 막힌건 아니긴 합니다만... 언제 PHP 5.6에서 문제가 생길지 알수 없으므로 미리 업그레이드하시는걸 추천드립니다)

    또한 코어 수정사항도 미리 정리해 두셔야 합니다.(git 등으로 관리해둔게 없으시다면)

    라이믹스를 덮어씌우면 수정사항도 지워지므로 사이트가 오동작할수 있습니다. 테스트 사이트 따로 만드신뒤 라이믹스 코드를 덮어씌우시고 코어 수정사항을 반영해 보시면 될것 같습니다.(제일 좋은건 git으로 변경사항 관리하는 것입니다)

  • profile profile
    답변 감사합니다.
  • profile profile
    라이믹스에서 적용된 프레임워크라던지 일부 composer 에 적용된 기본 기능들이 모두 7.0이상에서만 작동되기 때문에 이제는 점점 5.6 에서는 작동하기가 어려울 거예요.

    주기적으로 composer를 한번씩 업데이트 햇기에 그거때문에라도 최소버전이 올라갓거든요 ㅎㅎ;;
  • profile
    결국은 사전 테스트 후 가능이네요 ^-^감사합니다.