질문/조언질답게시판
Extra Form
PHP PHP 7.1
CMS Rhymix

nginx 버전은 1.10.3

openssl 버전은 1.1.0h 입니다.

 

그래서 http2를 적용하기 위해서는 listen 443 ssl 뒤에 http2만 넣으면 된다고 해서 http2를 넣고 nginx를 재시작 했더니 502 에러가 나옵니다.

 

현재 nginx의 설정은 이렇게 되어 있습니다.

server {

    server_name fcseoulite.me; 

    root /usr/share/nginx/html; 

    index index.html index.php;
    
    client_max_body_size 32m;

    location / { 
        index index.php index.html;
    }

    include snippets/rhymix.conf;

    location ~ [^/]\.php(/|$) {
        fastcgi_split_path_info ^(.+?\.php)(/.*)$;
        if (!-f $document_root$fastcgi_script_name) { 
            return 404;
        }
        fastcgi_pass unix:/run/php/php7.1-fpm.sock;
        fastcgi_index index.php;
        fastcgi_param HTTPS on;
        include fastcgi_params;    
    }

    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/fcseoulite.me/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/fcseoulite.me/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

  • profile
    listen 443 ssl http2; 이렇게 적용 하시면 될텐데요?
  • profile profile
    그러게요.. 분명히 http2; 붙이면 될텐데 자꾸 502가 떠서...
  • profile
    에러로그를 살펴 보시면 해결책이 보일겁니다.