질문/조언질답게시판

제가 사용하는 호스팅이 카페24인데. 아무것도 모르고 시작했는데.

 

UTF-8 (PHP5.5, MySQL5.x)

 

PHP 버전이 5.5 이네요.ㅠㅠ 이게 보안 업데이트가 더이상 지원안된다고 해서 보안에 아주 취약하다고 들었습니다.ㅠㅠ

 

이걸 업데이트 하려면 돈을 더줘서 상위버전으로 가야되는건지 아니면 FTP 자체에서 상위버전으로 설치할수있는지요.

 

아무것도 모르고 시작해서 하나하나 배워가는중인데 보안이 너무 어렵네요.

  • profile
    cafe24측에서 따로 설정 가능합니다.
    설정시 데이터 및 디비가 초기화 될 수 있으니 백업을 받아 복구할 수 있도록 하세요
  • profile ?
    아 찾았는데요. PHP 7.3 PHP 7.0 PHP 5.3 PHP 5.2

    버전이 생각보다 많아서 혹시 어떤걸로 해야되나요?

    그리고 디비랑,데이터빽업해두고 복구하면 정상적으로 다작동 되나요 ^^; 해본적이 없어서요.
  • ? profile
    7.0으로 하시는것이 좋겠네요.
  • profile
    php5 <<<<<< 속도 넘사벽 <<<<<< php7 over
  • profile ?
    이말은 php5에서 7로 업데이트하면 속도가 많이 느려진다는 말인가요?
  • ? profile
    7.0 더 빠르답니다.
  • profile ?
    답변 감사합니다.ㅠㅠ 결국 업글해야되는군요.,
  • ?

    7.3이 제일 빠르지만, 7.2 이상 버전을 쓰려면 object->baseobject 치환해줘야 하니 직접 코딩을 해야합니다.
    5.3~7.1 은 소스코드가 거의 다 호환됩니다.
    즉 7.1 이하 중에 cafe24에서 제공하는 제일 높은 버전인 7.0 을 추천합니다.

  • ? ?
    아 7.0이상은 어렵나보군요! 추천버전 감사합니다.:)
  • ?
    카페24에서 5.5에서 7.0으로 변경안될껍니다
    다시 7.0으로 새로 시작하셔야되요
  • ? ?
    카페24에서는 변경이 안되나요.ㅠㅠ 그럼 홈페이지를 다시 만들어야되나요ㅠㅠ

서버에 요청 중입니다. 잠시만 기다려 주십시오...