질문/조언질답게시판

이 문제가 저만 그런건가요?

혹시 똑같은 문제 있으신 분 안 계신가해서 질문 올립니다.

 

현재 모든 게시판 새 글 등록 하면 정상적으로 작동합니다.

XE 샤용중일 때는 간단한 글이건 이미지가 많은

글이건 상관없이 3-6초 정도 걸렸던 걸로 기억됩니다.

라이믹스로 업그레이드 한 후에 이 문제가 사라졌죠.

이제는 '서버에 요청 중입니다' 라는 프로그레스 바는

거의 보기 힘들 정도입니다.

XE사용하던 예전에 비하면 그야말로 광속이죠. 

 

그런데 이상하게 유됵 익명 게시판에 댓글만 달면 간단하게 test라는 

댓글을 달아도 '서버에 요청 중입니다'라는 프로그레스 바가

항상 7번 정도 돌아야 글이 등록 됩니다. 댓글만 그렇습니다.

새 글 등록은 다른 게시판과 마찬가지로 정상작동 합니다.

 

처음엔 애드온 때문인가? 라고 생각했습니다.

https://xetown.com/tips/3871

 

그런데 이 애드온을 꺼도 마찬가지더군요. 

게시판 스킨을 이것 저것 다른 것으로 바꿔도 같은 현상이구요.

 

마침내 게시판 정보 설정에서 이 옵션을 끄니까

새 글, 댓글 모두 정상적으로 작동합니다.

혹시 같은 증상 겪으시는 분 계시는지요?

 

anonymous.PNG

Atachment
첨부 1
  • profile
    라이믹스 디버그 기능을 사용하면 어느 애드온이나 모듈이 시간을 많이 잡아먹는지 파악할 수 있습니다.
  • profile ?
    도무지 알 수가 없네요. 애드온이나 모듈과의 문제가 아닌듯 한데요. 4초 이상 딜레이 되는 거 다 로그하라고 했는데 안 나오네요. 애드온도 하나 하나씩 끄고 해봐도 댓글 다는 시간은 별 진전이 없고, 단지 익명 기능을 끄면 댓글이 정상이 됩니다. ㅡㅡ
  • ? profile
    딜레이 1초로 한뒤 테스트 해보세요.
  • profile ?
    1초로 하고 테스트 해봤는데 걸리는 게 없는 것 같습니다. 분명 댓글 달 때는 5~7초 정도 걸렸습니다.
    General Information
    Request: GET
    Response: HTML - 88113 bytes
    Total Time: 0.3368 sec
    Query Time: 0.0446 sec (count: 101)
  • ? profile

    그럼 실제로 요청시간에 무언가 걸리는게 있는지 없는지 확인해보세요,. 아니면 실시간으로 액션값을 취할때 다른 작업을 하는것이 있는지 확인해보시거나요..

    그리고 댓글 달기 글쓰기 같은 경우에는 보통 Request는 GET이 아니라 POST가 나와야 정상입니다.

  • profile ?
    두 분 신경 써주셔서 너무 감사합니다. 아무 것도 한 것은 없지만 결국 삭제하고 새 게시판을 만드는 걸로 해결은 했습니다. 디버그 로그는 GET 이고 POST 고 아무리 눈 빠지게 봐도 별 이상이 없었습니다. 그냥 또 다른 게시판을 만들어서 뭔가 하나하나 더할 때 마다 계속 테스트를 하는 방법으로 해결했네요. 새로 만든 게시판은 아무런 이상없이 잘 작동하고 있습니다.

서버에 요청 중입니다. 잠시만 기다려 주십시오...