물어보기Rhymix
Rhymix

php7.2 호환성

조회 수 135 댓글 2
Extra Form

 어제 서버를 다시 셋팅하면서 php7.2로 설치를 하였는데요

아직 이전은 하기 전이지만 여러 모듈이나 애드온들의 호환이 잘 안된다는 말이 있어서 당장 서비스가 안될까 염려가 됩니다

php7.0으로 다운 그레이해서 사용 하는 것이 좋을까요?

여러분들의 의견이 궁금합니다

감사합니다.

  • profile
    웹지기 2018.06.08 10:26:44

    사용하시는 모든 서드파티 자료를 내려 받으 신 후
    Object(...) 를 BaseObject(...) 로 변경 하셔야 합니다.

    에디터 프로그램에서 일괄 변경하면 쉽게 하실 수 있습니다.



    해당 서드파티 자료들을 최신코어가 아닌 곳에서도 사용하려면


    return new Object(-1, 'errmsg');
    $output = new Object();
    // 이와 같이 사용했다면 아래와 같이 변경

    return class_exists('BaseObject') ? new BaseObject(-1, 'errmsg') : new Object(-1, 'errmsg');
    $output = class_exists('BaseObject') ? new BaseObject() : new Object();

    https://github.com/xpressengine/xe-core/issues/2181

    https://www.xpressengine.com/devlog/23249915

  • profile
    아티스터디 2018.06.08 14:42:17
    제가 직접 7.2에 이것저것 돌려봤었습니다. 사실상 서드파티중 멀쩡히 돌아가는건 없다고 보시면 됩니다...

서버에 요청 중입니다. 잠시만 기다려 주십시오...