물어보기서버관련
조회 수 128 추천 수 0 댓글 4
Extra Form

일단 default.conf에는 아래같이 썼거든요? 서브도메인인데 뭔가 문제가 있을지..

 

server {
    listen 80 default;
    server_name 45.77.181.159;
    root /var/www_ip;
}

server {
    listen 80;
    listen [::]:80;
    server_name  pro.cookiee.net;
    return 301 https://$server_name$request_uri;
}

server {
    listen  433 ssl http2 default_server;
    listen  [::]:433 ssl http2 default_server;
    server_name  pro.cookiee.net;
    
    root   /usr/share/nginx/html;
    index  index.php index.html;
    
    if ($host != 'pro.cookiee.net' ) {
    rewrite ^/(.*)$  https://pro.cookiee.net/$1 permanent;
    }

    charset utf-8;
    #access_log  /var/log/nginx/host.access.log  main;

    location ~ /.well-known {
        allow all;
    }
    
    ssl_certificate /etc/letsencrypt/live/pro.cookiee.net/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/pro.cookiee.net/privkey.pem;
    ssl_trusted_certificate /etc/letsencrypt/live/pro.cookiee.net/chain.pem;
    ssl_dhparam /etc/nginx/ssl/dhparams.pem;
    
    ssl_session_tickets on;
    ssl_session_ticket_key /etc/nginx/ssl/session_ticket.key;
    
    location ~ \.php$ {
        fastcgi_pass unix:/run/php/php7.1-fpm.sock;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME /usr/share/nginx/html$fastcgi_script_name;
    }
    
    location ~ /\.ht {
        deny all;
    }


    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   /usr/share/nginx/html;
    }
    
    add_header X-Frame-Options SAMEORIGIN;
    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
}

 

pro.cookiee.net인데 자꾸 접속하면 아래같이 연결을 거부했다네요..

asdffffssd.PNG

 

또 크롬에 시큐리티 탭에서 보면 아래같이 뜨고요..

 

asssd.PNG

어떻게 해야 해결할수 있을까요?

 

우분투 환경입니다.

letsencrypt 사용해서 만들었고요

  • profile
    라라펠 2018.03.09 15:30:44

    443을 방화벽에 추가하셨나요?... ufw

  • profile
    YJSoft 2018.03.09 15:33:15

    listen 433 ssl http2 default_server;

    listen [::]:433 ssl http2 default_server;
    433이 아니라 443입니다.

     

    https://pro.cookiee.net:433/

    단순히 포트번호를 잘못 적으신게 원인으로 보이며 위 주소로 접속해보시면 인증서 적용은 정상적으로 이루어진걸 확인하실수 있습니다.

  • 라라펠 2018.03.09 15:39:02
    자연스러워서 눈치를 못챈 ㄷㄷ; 역시 눈썰미가 좋으신듯...
  • 리버스 질문자 2018.03.09 17:08:45
    아 ㅋㅋㅋ 그랬던거군요 ㅋㅋㅋㅋ
    뭐가 문제인지 하면서 쩔쩔멨었는데 오타가 문제였군요 ㅋㅋ 감사합니다!

서버에 요청 중입니다. 잠시만 기다려 주십시오...