물어보기Rhymix
조회 수 184 댓글 16
Extra Form

안녕 하세요. 아파치입니다.

 

정말 오랜만에 라이믹스 설치 해보려고 

 

git clone --depth=1 --branch=master https://github.com/rhymix/rhymix.git 으로 설치를 했습니다.

 

nginx, php7.1, mariadb 10.2 셋팅으로 설치를 진행했는데 맨마직막에 db및 패스워드 설정하고 다음으로 넘어가면

 

설치중이란 안내도 없이 500 에러 페이지가 뜹니다.

 

혹시 라이믹스 1.9.3 버전은 php 7.1에 아직 설치가 안되는 건가요?

 

php 버전을 낮추어 php7.0에서는 정상 설치가 진행이 되네요......ㅠㅠ

 

아래 링크는 php 7.0에서 설치한 사이트 입니다.

https://rx.jsbuilder.net/

  • ?
    란제리 2018.01.13 17:32:09
    최신 라이믹스 php7.1 잘 돌아갑니다.
    틀렸을수도 있는데 mariadb 10.2 에서 10.1 로 해서 해보세요
    mariadb 10.2 는 여러조건이 까다롭다고 합니다.
  • profile
    아파치 2018.01.13 17:34:44
    마리아db는 문제가 없는것 같은데요.
    본문에 써두었듯이 php7.0, 마리아db10.2에서 정상 설치가 되었거든요....ㅠㅠ
  • profile
    사과맛스타 2018.01.13 17:41:00
    7.1에서 잘 설치가 될텐데 이상하네요!
    php-fpm 으로 php 버전만 변경한건가요?
  • profile
    아파치 2018.01.13 17:45:23

    네. 그래서 브렌치를 develop 로 바꾸어 설치 해 보려구요.

  • profile
    기진곰 2018.01.13 18:03:51

    500 에러라면 당연히 어딘가에 에러메시지가 있을 텐데

    아실 만한 분이 이러시면 곤란합니다.. ㅋㅋㅋ

  • profile
    아파치 2018.01.13 18:12:02
    에러 메세지가 이렇게 뜨네요....ㅠㅠ
    Call to undefined method BaseObject::executeQuery() in /home/rhymix/master/public/common/legacy.php:144

    해당 파일의 구문이구요.
    return $oDB->executeQuery($query_id, $args, $arg_columns);
  • profile
    기진곰 2018.01.13 18:50:11
    디비 접속이 안되고 있는 듯 하네요.
  • profile
    아파치 2018.01.13 18:47:54

    제가 잘못 알았네요. 마리아db는 10.1.30 입니다.
    아무래도 php7.1에서는 db와 연결이 안되는듯 한데 어딜 손봐야 할지 감이 안오네요.....ㅠㅠ

  • profile
    사과맛스타 2018.01.13 20:12:26
    맨처음 php7.1 설치시 ./configure 로 설정하실 때 —with-mysqli 와 같은 db 관련 설정을 안하신거 아닐까요?
  • profile
    아파치 2018.01.13 20:41:11
    소스 설치가 아니고 yum으로 설치 했습니다....^^;;
    여지껏 찾고 있는데 모르겠네요. 7.0에선 되고 7.1에서 안되니 멘붕상태네요.
    라이믹스가 저하곤 안맞는지......ㅠㅠ
  • profile
    사과맛스타 2018.01.13 20:45:42
    7.1에서 다른 웹 소스들은 잘 설치가 되는거죠?
  • profile
    아파치 2018.01.13 20:57:59

    그누보드5는 잘 설치가 됩니다.

    그리고 php7.0으로 설치후 7.1로 바꾼후 접속하니 로그인이 안되네요?
    무슨 관계가 있는건지..... 혹시 rewrite 룰이 이전과 변경된적이 있나요?

  • profile
    사과맛스타 2018.01.13 21:43:24
    그러지는 않았을겁니다.

    아, 하위 폴더와 관련해서 .htaccess 파일이 수정된 적은 있습니다. 약 3개월 전쯤에요.
  • profile
    구미호 2018.01.14 01:06:29
    500 에러 기진곰님이 알려준 것을 제거후에 설치를 하니 잘돌아 갑니다
    저번 500에러 저는 잡았습니다 ㅎㅎㅎ 여러가지로 문제가 있으니 아파치님 잘하시니 근방 잡을것 같아요
  • profile
    아파치 2018.01.14 14:14:04
    어제 밤새 찾아 보았는데 해결이 안되네요....ㅠㅠ

    7.0에서는 정상 설치가 진행되고 7.1에서만 설치가 진행이 안되고 있습니다.
    에러 메세지에는 Call to undefined method BaseObject::executeQuery() in /home/rhymix/master/public/common/legacy.php:144 만 뜨고 있고....흐미~

    일단 제서버에서는 7.0만 사용해야 할듯 싶고 아파치 서버에서는 어떨까 모르겠네요.
  • profile
    구미호 2018.01.14 14:15:43
    역시 어느정도 해결을 하시줄 알았습니다 +_+

서버에 요청 중입니다. 잠시만 기다려 주십시오...