자유광장자유

혹시나 VPS 서버 세팅 하시는 분들을 위해 글 남깁니다.

 

실사용을 위한 사이트라면 우분투 16.04 LTS로 하세요.

18부터 php 7.2.5가 자동으로 설치되는데

일반 유저가 자주 사용 하는 모듈들 박살나는게 너무 많습니다.

몇일동안 삽을 어지간히도 펐는데..헛고생을 했습니다..

 

리노드 도쿄서버인데 속도도 괜찮고..

카페24쓰다가 용량부족때문에 넘어왔는데 매우 만족합니다.

  • profile
    기진곰 2018.05.26 16:40:43

    ppa:ondrej/php를 사용하면 우분투 18.04에서도 PHP 5.6, 7.0, 7.1을 apt-get으로 설치할 수 있습니다. 이미 다운그레이드하셨다면 어쩔 수 없지만, 우분투 18.04 사용하실 다른 분들은 참고하세요^^

  • profile
    아티스터디 2018.05.26 16:54:44
    한 3년 뒤에 php 7.2에서도 서드파티들이 잘 돌아가면 그때 다시 올려야겠어요.. :)
  • profile
    기진곰 2018.05.26 20:20:50
    우분투 16.04 유효기간이 딱 2년 11개월 남았습니다 ㅋㅋㅋ
  • profile
    도라미 2018.05.29 15:38:52
    이런 PPA들을 믿고 사용할 만 한가요...?
    공식 패키지가 아니면 좀 의심 가긴 하더군요
  • profile
    기진곰 2018.05.29 15:54:04

    ppa:ondrej/php 운영자는 우분투 PHP 패키지 관리팀 소속이예요. 우분투 정책상 공식 제공할 수 없는 버전의 패키지를 개인 자격으로 따로 제공하는데, 거의 공식 취급입니다.

  • profile
    도라미 2018.05.29 15:59:50
    우분투 공식 PHP 보단 보안패치 지원이 짧겠군요..
  • profile
    아티스터디 2018.05.29 17:40:49
    딱 맞춰서 바꿔야겠네요..ㅋㅋㅋ

서버에 요청 중입니다. 잠시만 기다려 주십시오...